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A computer is  a programmable device  that  stores,   retrieves,   and 

processes data.     The     term computer is derived      from      the      Latin  

term ‘computare’, this means to calculate or programmable machine. It is a 

device that accepts information (in the form of digitalized data) and 

manipulates it for some result. 

Charles Babbage is called the "Father" of the computer. The First mechanical 

computer designed by Charles Babbage was called Analytical Engine. It uses 

read-only memory in the form of punch cards. 

Computer is an advanced electronic device that takes raw data as input from 

the user and processes these data under the control of set of instructions 

(called program) and gives the result (output) and saves output for the future 

use. It can process both numerical and non-numerical (arithmetic and logical) 

calculations. 
 

Input (Data): 
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Input is the raw information entered into a computer from the input devices. 

It is the collection of letters, numbers, images etc. 

Process: 

Process is the operation of data as per given instruction. It is totally internal 

process of the computer system. 

Output: 

Output is the processed data given by computer after data processing. Output 

is also called as Result. We can save these results in the storage devices for 

the future use. 

The four functions of a computer actually explain the core reasons why it was 

built. They include: 

 Data input 

 Data processing. 

 Information output. 

 Data and information storage. 

 

 
Characteristics of computer 

 
 

 Speed 

 Accuracy 

 Memory 

 Diligence 

 Versatility 

 Reliability 
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Speed: 

 
Hmmm let’s talk about speed, Computers have an incredible speed with 

accuracy that is beyond human capabilities, Not only they have speed but the 

speed with accuracy and Pinpoint solutions to every problem arises before 

them. 

The speed of the computer is considered one of the most important 

characteristics of computer.. As per human beings, the smallest unit of time is 

considered to be second, but not for computers seconds are further divided 

into milliseconds, microseconds, nanoseconds and microseconds. The 

powerful PC can work almost 5 million instructions per second. When we 

discuss the speed of computer milliseconds are hundredth of a second, 

microseconds are the millionth of a second, nanoseconds are the billionth of a 

second, and picoseconds are trillionth of a second. 

Speed is primarily the main characteristic of computer, their speed is 

measured in terms of GIGAHERTZ and MEGAHERTZ. They can solve complex 

to complex numerical and logical problems with ease compared to human 

beings. 

Accuracy: 

 
They have a great speed and are unbelievably deadly accurate. The Errors 

occurs due to improper or wrong or inaccurate input given to the computer 

system. PC primarily depends upon the inputs. Say if a user enters wrong or 

improper or inaccurate information to the computer obviously the output 

generated by them will be wrong, improper or inaccurate. 
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Memory: 

 
This is also one of the most essential characteristics of computers these days 

they can store or save almost any volume of data due to its high storage 

capabilities. Once the data or instruction saved to the computer memory it 

remains in the memory, until and unless someone deletes, users can recall or 

retrieve the data anytime, at any location they require, As the human being 

tends to forget small information given to them, but these machines stores all 

the information was given to them permanently. 

These Machines can store the data as long as the user’s desire. The 

measurement of memory is MEGABYTES (MB), GIGABYTES (GB) And 

TERABYTES (TB).Hard disk and pen drives are examples of memory. 

Diligence: 

 
They can work long hours without tiredness or boredom with the same speed 

and accuracy. As the computer is a machine it does not refuse to work and 

works for hours and hours with the same consistency. 

But on the other hand human being can get easily tired of the same work 

repeatedly can lose their concentration, speed, and accuracy because humans 

suffer from tiredness, laziness, unlike machines. 

Versatility: 

 
They can perform several tasks at the same time, such as user can play songs, 

work on documents, search for any documents in the hard disk, surf the net, 

download software, calculate, a computer can perform several functions at 

the same time with same speed, accuracy and with consistency. 
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Reliability: 

 
They are reliable machines, because of the reliability of many organizations, 

institutions, companies rely on them hugely. They can store huge amounts of 

data and can be recalled or retrieve quickly at any time or any place as the 

user demands. 

The errors that occur in the computer are all human errors. Once given a 

huge task or operation they complete the work without any excuses and 

people or users can rely on them. 
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Types of computer system 

PC (Personal Computer) 
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A PC can be defined as a small, relatively inexpensive computer 
designed for an individual user. PCs are based on the 
microprocessor technology that enables manufacturers to put an 
entire CPU on one chip. Businesses use personal computers for 
word processing, accounting, desktop publishing, and for running 
spreadsheet and database management applications. At home, the 
most popular use for personal computers is playing games and 
surfing the Internet. 

Although personal computers are designed as single-user systems, 
these systems are normally linked together to form a network. In 
terms of power, now-a-days high-end models of the Macintosh and 
PC offer the same computing power and graphics capability as low- 
end workstations by Sun Microsystems, Hewlett-Packard, and Dell. 

 
 
 
 

 
Workstation 
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Workstation is a computer used for engineering applications 
(CAD/CAM), desktop publishing, software development, and other 
such types of applications which require a moderate amount of 
computing power and relatively high quality graphics capabilities. 

Workstations generally come with a large, high-resolution graphics 
screen, large amount of RAM, inbuilt network support, and a 
graphical user interface. Most workstations also have mass storage 
device such as a disk drive, but a special type of workstation, called 
diskless workstation, comes without a disk drive. 

Common operating systems for workstations are UNIX and 
Windows NT. Like PC, workstations are also single-user computers 
like PC but are typically linked together to form a local-area 
network, although they can also be used as stand-alone systems. 

Minicomputer 

It is a midsize multi-processing system capable of supporting up to 
250 users simultaneously. 
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Mainframe 

Mainframe is very large in size and is an expensive computer 
capable of supporting hundreds or even thousands of users 
simultaneously. Mainframe executes many programs concurrently 
and supports many simultaneous executions of programs. 
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Supercomputer 

Supercomputers are one of the fastest computers currently 
available. Supercomputers are very expensive and are employed for 
specialized applications that require immense amount of 
mathematical calculations (number crunching). 

 

For example, weather forecasting, scientific simulations, (animated) 
graphics, fluid dynamic calculations, nuclear energy research, 
electronic design, and analysis of geological data (e.g. in 
petrochemical prospecting). 

Tablet 

A tablet, tablet computer, or tablet PC is a mobile computing device 

designed to be held in one or two hands. It is approximately the size 

of a hardcover book (seven inches or bigger), and resembles a 

large Smartphone. 
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Early tablet devices used light pens or a stylus as their input device. 

However, today all tablets use a touch screen as their primary input 

device with the option to connect external devices, such as a 

keyboard. Most tablets only have a few physical buttons; the back, 

power, and volume buttons. Everything else can be done using your 

fingers. 

Laptop 

A laptop (also laptop computer), is a small, portable personal 

computer (PC) with a "clamshell" form factor, typically having a 

thin LCD or LED computer screen. 
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A Laptop computer (also called portable computer or notebook 

computer in English) (Other terms, such as ultra book or net book, 

refer to specific types of laptop) is designed with portability in mind. 

It was developed in the late 1980s. It is briefcase style with a foldout 

screen with a clamshell form factor, suitable for mobile use and with 

a miniature keyboard. It is small enough to use in your lap. The 

laptop is battery or AC-powered personal computer that should be 

charged via a plug and socket, and when it runs out of power, it must 

be recharged regularly. 

For fundamentals of computer system & Memory and its types ( 

Primary memory and secondary memory) click on link below 

https://www.youtube.com/watch?v=XAManVWcBDs 

for secondary storage devices click on link below 

https://www.youtube.com/watch?v=cxVCRcqyPJA 

Input Devices 

The devices which are used to give data and instructions to the 

computer are called Input Devices. Various types of input devices 

can be used with the computer depending upon the type of data you 

want to enter in the computer, e.g., keyboard, mouse, joystick, light 

pen, etc. 

Keyboard 
 

It is the most commonly used input device. It is used to enter data 



PAPER – III (FOUNDATION COURSE) 
 

 

and instructions directly into the computer. There are 104 buttons 

on the keyboard which are called keys. 

 
The keyboard was invented 134 years ago by Christopher L. Sholes. 

Mouse 

Mouse is another input device which is commonly found connected 

with the computers. It is basically a pointing device which works on 

the principle of Point and Click. When the mouse is moved on the 

mouse pad, a light beam underneath reflect to give motion to the 

pointer on the screen. 
 

The mouse is used in windows based programs, where the user can 

run the commands by pointing the objects with the help of pointer 

and clicking the buttons on the mouse. We also use mouse for 

drawing in paint and kid pix. 

Most of the latest mouse, these days, include a wheel in the middle 

of two buttons that help us to scroll through documents more easily. 

we use our forefinger to move the wheel to scroll up or down in a 

document. Optical mouse uses red light to track the movement of 

mouse for moving the pointer on the computer screen. This type of 

mouse is more accurate and reliable than the traditional mouse. 
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Nowadays cordless mouse is very popular. it dose not have wires. it 

either uses Bluetooth technology to sends the data through the air to 

a receiver, usually plugged in USB port of the computer. 

Joystick  and Game-pad 

Joystick and game-pad are also input devices which are also input 

devices which are used to control the movement of object on the 

screen. Just like mouse, these are also pointing devices. Mostly they 

are used for playing games on the computer. 

The joystick has a vertical stick with a track ball at its bottom. While 

playing the games on the computer, the user needs to move the 

objects quickly on the screen. With the movement of this vertical 

stick the objects can be moved in all the directions easily. 

A game-pad is a type of game controller held in two hands, where 

the fingers (especially thumbs)are used to provide input by pressing 

buttons on it. It is also known as Control Pad. 

Light Pen 
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Light pen is another pointing type input device. It is a pen shaped 

device which can be used by directly pointing the objects on the 

screen. It can also be used for making drawings directly on the 

monitor screen. 

Scanner 
 

We can store pictures, photographs, diagrams into the computer 

with the help of scanner. The scanner reads the image and saves it in 

the computer as a file. 

Touchscreen 
 

 

Touchscreen is a special computer screen that takes the input by 

sensing the touch of a human finger, gloved hand, stylus, pen or any 
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other pointing device. The user gives instructions to the computer 

just by touching the screen. 

Microphone 
 

This is an input device which is used to record sound or voice into 

the computer system. You can store voice data in the computer by 

speaking in front of this device. 

Trackball 

A trackball is similar to a mouse but is mounted in a fixed position. 

The user spins the ball with fingers to move the pointer on the 

screen. 

A Trackball technology was used in earlier laptop computer which is 

now replaced with track-pad. 

Think and Answer 

Name any two input devices you commonly use while working on 

computer. 

Output Devices 

The devices which are used to display the results or information are 
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called Output Devices. You can view the output on the monitor or 

you can print it on a paper using a printer. Monitor and the printer 

are the commonly used output devices. 

Monitor 

This is the most common output device connected with the 

computer to display the processed information. It looks like a TV 

and is also know as VDU(Visual Display Unit). Pictures are displayed 

by using a large number of very small dots on screen called pixels. 

The number of pixels that a monitor can show on its screen is 

referred to as the resolution of the screen. 

 

 

 
The two commonly used monitor types are: 

Cathode Ray Tube(CRT)Monitor 

Liquid crystal Display(LCD)Monitor 

Add to Your knowledge 

LCD uses very small amount of electricity as compound to CRT. 
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The output produced on the screen is called Soft Copy Output 

because it cannot be retained for a long time. 

Nowadays LCD monitors are more popular as their sharp picture 

quality. They are light weighted and flat screen monitors. 

Printer 

This is an important output device of the computer system. It gives a 

printed output of the results that appears on the monitor screen. 

Printed output is also called Hard Copy output because unlike 

monitor, this output can be preserved even if the computer is 

switched off. 

Printers are of different types. On the basis of their printing 

techniques, printers are grouped as follows: 

1. Character printer 

2.Line printer 

3.Page printer 
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Character Printer 

Character printer prints one character at a time; it prints at the 

speed of around 30 to 600 characters per second. 

Dot Matrix printer is an example of a character printer. 

Dot Matrix Printer 

This type of printer works like a typewriter. It creates an impression 

on the paper by pressing the end of pins fixed in its print heads, 

against an inked ribbon. This printer is noisy with a low print 

quality. Its speed is measured in CPS(Characters Per Second). 

Line Printer 

This is high speed printer that prints one line at a time. It is used 

when large quantity of output is required as it produces the quick 

output. Examples of a Line printer are Drum printer and the Chain 

printer. The noise level of these printers is high and speed ranges 

from 200 to 2000 LPM (Lines Per Minute). 

Page Printer 

Page Printer prints a whole page at a time. Examples of these 

printers are inkjet printer or a Line printer because it has to store 

each page in memory before printing it. 

Inkjet Printer 

This type of printer prints by spraying tiny ink droplets on the 

paper. It can print in both, color as well as black and white. The print 

quality of this printer is better than that of Dot Matrix Printer and it 

prints without making any noise. Its speed is measured in 

PPM(Pages Per Minute). 
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Add to your knowledge 

The most commonly used printers are: Dot matrix, inkjet and Laser 

printers. 

Laser printer 

In this type of printer, laser beam technology is used to print the text 

or graphics on the paper. The speed of this printer is very fast and it 

gives out very fine quality prints. It’s speed is also measured in PPM. 

Speaker 
 

Speakers are categorized as output devices. These are used to listen 

to the music and sounds played by the computer. Normally they 

come in a pair and have different shapes and sizes. 

Plotter 

We can get the print of a photograph, drawing, image stored in the 

computer, by using a plotter. It is an output device which provides a 

high quality of printed output. It is generally used by engineers and 

architects. 

CRT Monitor 
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A monitor displays text and image data passed to it by the computer. 

A cathode-ray tube (CRT) monitor is the type that has been around 

for years and is large and boxy. 

CRT monitors are heavy and they take up a lot of desk space. They 

have largely been replaced by flat-screen monitors. However some 

are still used in the design industry since the color 

accuracy and brightness of CRT monitors is excellent, and designers 

need to see true-to-life colors. 

Also, CRT monitors are generally cheaper than flat-screen monitors. 
 

Flat-Screen Monitor (TFT or LCD) 

Over the past few years, as they have come down in price, flat- 

screen displays have replaced CRT monitors. 

Flat-screen monitors are light in weight and they take up very little 

desk space. 

Modern flat-screen monitors have a picture quality that is as good as 

CRT monitors. 
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TFT and LCD are two of the technologies used in flat-screen 

monitors: TFT is Thin-Film-Transistor, and LCD is Liquid-Crystal 

Display. 

Another technology that may replace these is OLED, or Organic 

Light-Emitting Diodes. 

Digital / Multimedia Projector 

Digital projectors are used in situations when a very large viewing 

area is required, for example during presentations, for advertising, 

or in your home for watching movies. 
 

A projector connects to a computer, a DVD player or a satellite 

receiver just like a ordinary monitor. 
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The image is produced inside the device and then projected out 

through a large lens, using a powerful light source. 

Video standards:- 

Video Graphics Array (VGA) 

Short for Video Graphics Adapter or Video Graphics Array, VGA is a 

popular display standard developed by IBM and introduced in 1987. 

VGA provides 640 x 480 resolution color display screens with 

a refresh rate of 60 Hz and 16 colors displayed at a time. If the 

resolution is lowered to 320 x 200, 256 colors are shown. 

VGA utilizes analog signals, which means it's only capable of lower 

resolutions and a lower quality display on screens. The VGA connector 

is used for display devices and is used to connect a computer to 

a monitor, projector, or TV. 
 

Super Video Graphics Array (SVGA) 

Short for Super Video Graphics Array, SVGA is a set of 

video standards one step above VGA. SVGA monitors are capable of 
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displaying up to 16 million colors with a resolution of 800 x 600 on 

14-inch monitors and up to a 1200 x 1600 resolution on a 20-inch. 

 

                        The picture shows what the typical VGA/SVGA connection. Today,     

SVGA is being phased out by the connection known as DVI. 

Extended Graphics Array (XGA) 

Extended Graphics Array (XGA) is a computer display standard that 

provides 1,024 by 768 pixels in 256 colors, or 640 by 480 pixels in 

16-bit color. It is a proprietary standard that was originally intended 

to replace the earlier VGA (Video Graphics Array) display mode, but 

as it was quickly replaced by superior technology, it instead became 

simply known as part of the VGA family (with other formats like 

SVGA and UVGA). IBM developed VGA in 1987, and XGA followed in 

1990. While VGA was limited to a standard resolution of 640 by 480 

in 16 colors, XGA had the ability to increase color depth at that 

resolution to 16-bit, or to increase to a higher resolution of 1,024 by 

768 in 256 colors. 
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Unit II 

Operating system 

 

The Operating System of a computer can be defined as a collection of software modules 

which extend the computer hardware and make it more convenient and easier to use for 
other programs. In other words it "converts" real computer with hardware resources into a 
virtual machine with virtual resources. 

 

Therefore, all software may be divided into two broad categories: 
System Software, which runs on hardware resources (e.g. MacOS, Windows) and User 
Software, which runs on virtual resources provided by operating system (e.g. MS Word, 
Adobe Photoshop). Every computer needs to have operating system in order to run any 
end-user application. 

 
An Operating System is a set of programs that controls and coordinates the use of 
computer hardware among various application programs. It provides an environment within 
which user can execute programs. A computer can be divided into four components: the 
hardware, the operating system, the applications programs, the users. It is the operating 
system that manages all the above components.  The various functions of the operating 
system are: 

 Controlling Input/Output devices (Keyboard, Mouse, Monitor, Printer, Plotter etc...) 
 Booting the computer 
 Memory and File storage management 
 CPU Scheduling and controlling processes 

 Loading, initiating, executing and supervising user applications programs 
 Handling errors and restarting 

 Providing command interface between user and computer system 

Examples of Operating system are : UNIX (Solaris, IRIX, HPUnix, Linux, DEC Unix) 
Microsoft Disk Operating System (MS-DOS), WIN95/98, WIN NT, OS/2 etc. 

 

An operating system is a group of computer programs that coordinates all the activities 
among computer hardware devices. It is the first program loaded into the computer by a 
boot program and remains in memory at all times. 

 

                                 Types of interface 

CUI: character user interface or command-line user interface, CUI is a prompt used to interact 

with computer programs. It works by allowing the user (client) to issue commands as one or  
more lines of text (referred to as command lines) to a program. One of the CUI's uses is that it 
provides an easy way to implement programming scripts. The command-line user interface was 
the primary method of communicating with a computer from the first machines, all the way 
through the 1980s. Although it may still be accessed in most of today operating systems, it is 
utilized far less due to the ease of use and familiarity of the graphical user interface (GUI). The 
CUI, however, is still preferred by many advanced end users as its features provide them with 
more comprehensive control over an operating system's functions. Good examples of command 
lines include MS-DOS, Windows command line, Terminal, and the Linux command line. 

 

 



GUI: GUI is what most modern computers make use of. This is an interface that makes use 
of graphics, images and other visual clues such as icons. This interface made it possible for a 
mouse to be used with a computer and interaction really became very easy as the user could 
interact  with just a click of the mouse rather than having to type every time to give 
commands to the computer. Modern operating systems use a graphical user interface, or GUI 
(pronounced gooey). A GUI lets you use your mouse to click icons, buttons, and menus, and 
everything is clearly displayed on the screen using a combination of graphics and text. 

  

             Types of Operating Systems 
An Operating System performs all the basic tasks like managing file, process, and memory. Thus 
operating system acts as manager of all the resources, i.e. resource manager. Thus operating 

system becomes an interface between user and machine. 
Types of Operating Systems: Some of the widely used operating systems are as follows- 
1. Batch Operating System – 

This type of operating system does not interact with the computer directly. There is an operator 
which takes similar jobs having same requirement and group them into batches. It is the 
responsibility of operator to sort the jobs with similar needs. 

 

 
Advantages of Batch Operating System: 
 It is very difficult to guess or know the time required by any job to complete. Processors of the 

batch systems know how long the job would be when it is in queue 
 Multiple users can share the batch systems 
 The idle time for batch system is very less 
 It is easy to manage large work repeatedly in batch systems 
Disadvantages of Batch Operating System: 
 The computer operators should be well known with batch systems 
 Batch systems are hard to debug 
 It is sometime costly 
 The other jobs will have to wait for an unknown time if any job fails 
Examples of Batch based Operating System: Payroll System, Bank Statements etc. 
 
 



2. Time-Sharing Operating Systems – 

Each task is given some time to execute, so that all the tasks work smoothly. Each user gets time of 
CPU as they use single system. These systems are also known as Multitasking Systems. The task 
can be from single user or from different users also. The time that each task gets to execute is called 
quantum. After this time interval is over OS switches over to next task. 

 

Advantages of Time-Sharing OS: 

 Each task gets an equal opportunity 
 Less chances of duplication of software 
 CPU idle time can be reduced 
Disadvantages of Time-Sharing OS: 

 Reliability problem 
 One must have to take care of security and integrity of user programs and data 
 Data communication problem 
Examples of Time-Sharing OSs are: Multics, Unix etc. 
 
3. Distributed Operating System – 

These types of operating system is a recent advancement in the world of computer technology and 
are being widely accepted all-over the world and, that too, with a great pace. Various autonomous 
interconnected computers communicate each other using a shared communication network. 
Independent systems possess their own memory unit and CPU. These are referred as loosely 
coupled systems or distributed systems. These system’s processors differ in size and function. The 
major benefit of working with these types of operating system is that it is always possible that one 
user can access the files or software which are not actually present on his system but on some other 
system connected within this network i.e., remote access is enabled within the devices connected in 
that network. 



 
 
 

Advantages of Distributed Operating System: 

 Failure of one will not affect the other network communication, as all systems are independent 
from each other 

 Electronic mail increases the data exchange speed 
 Since resources are being shared, computation is highly fast and durable 
 Load on host computer reduces 
 These systems are easily scalable as many systems can be easily added to the network 
 Delay in data processing reduces 
Disadvantages of Distributed Operating System: 

 Failure of the main network will stop the entire communication 
 To establish distributed systems the language which are used are not well defined yet 
 These types of systems are not readily available as they are very expensive. Not only that the 

underlying software is highly complex and not understood well yet 
Examples of Distributed Operating System are- LOCUS etc. 
 
4. Network Operating System – 
These systems run on a server and provide the capability to manage data, users, groups, security, 
applications, and other networking functions. These type of operating systems allow shared access 
of files, printers, security, applications, and other networking functions over a small private network. 



One more important aspect of Network Operating Systems is that all the users are well aware of the 
underlying configuration, of all other users within the network, their individual connections etc. and 
that’s why these computers are popularly known as tightly coupled systems. 

 

Advantages of Network Operating System: 
 Highly stable centralized servers 
 Security concerns are handled through servers 
 New technologies and hardware up-gradation are easily integrated to the system 
 Server access are possible remotely from different locations and types of systems 
Disadvantages of Network Operating System: 

 Servers are costly 
 User has to depend on central location for most operations 
 Maintenance and updates are required regularly 
Examples of Network Operating System are: Microsoft Windows Server 2003, Microsoft Windows 

Server 2008, UNIX, Linux, Mac OS X, Novell NetWare, and BSD etc. 
5. Real-Time Operating System – 

These types of OSs serves the real-time systems. The time interval required to process and respond 
to inputs is very small. This time interval is called response time. 

Two types of Real-Time Operating System which are as follows: 
 Hard Real-Time Systems: 

These OSs are meant for the applications where time constraints are very strict and even the 
shortest possible delay is not acceptable. These systems are built for saving life like automatic 
parachutes or air bags which are required to be readily available in case of any accident. Virtual 
memory is almost never found in these systems. 

 Soft Real-Time Systems: 
These OSs are for applications where for time-constraint is less strict. 



 

Advantages of RTOS: 
 Maximum Consumption: Maximum utilization of devices and system,thus more output from all 

the resources 
 Task Shifting: Time assigned for shifting tasks in these systems are very less. For example in 

older systems it takes about 10 micro seconds in shifting one task to another and in latest 
systems it takes 3 micro seconds. 

 Focus on Application: Focus on running applications and less importance to applications which 
are in queue. 

 Real time operating system in embedded system: Since size of programs are small, RTOS 
can also be used in embedded systems like in transport and others. 

 Error Free: These types of systems are error free. 
 Memory Allocation: Memory allocation is best managed in these type of systems. 
Disadvantages of RTOS: 

 Limited Tasks: Very few tasks run at the same time and their concentration is very less on 

few applications to avoid errors. 
 Use heavy system resources: Sometimes the system resources are not so good and they 

are expensive as well. 
 Complex Algorithms: The algorithms are very complex and difficult for the designer to write 

on. 
 Device driver and interrupt signals: It needs specific device drivers and interrupt signals to 

response earliest to interrupts. 
 Thread Priority: It is not good to set thread priority as these systems are very less prone to 

switching tasks. 
Examples of Real-Time Operating Systems are: Scientific experiments, medical imaging systems, 

industrial control systems, weapon systems, robots, air traffic control systems, etc. 
 
6.Multitasking Operating Systems 

Multitasking is when multiple jobs are executed by the CPU simultaneously by switching between 
them. Switches occur so frequently that the users may interact with each program while it is running. 
An OS does the following activities related to multitasking − 

 The user gives instructions to the operating system or to a program directly, and receives an 
immediate response. 



 The OS handles multitasking in the way that it can handle multiple operations/executes 
multiple programs at a time. 

 Multitasking Operating Systems are also known as Time-sharing systems. 

 These Operating Systems were developed to provide interactive use of a computer system at 
a reasonable cost. 

 A time-shared operating system uses the concept of CPU scheduling and multiprogramming 
to provide each user with a small portion of a time-shared CPU. 

 Each user has at least one separate program in memory. 

 

 A program that is loaded into memory and is executing is commonly referred to as 
a process. 

 When a process executes, it typically executes for only a very short time before it either 
finishes or needs to perform I/O. 

 Since interactive I/O typically runs at slower speeds, it may take a long time to complete. 
During this time, a CPU can be utilized by another process. 

 The operating system allows the users to share the computer simultaneously. Since each 
action or command in a time-shared system tends to be short, only a little CPU time is 
needed for each user. 

 As the system switches CPU rapidly from one user/program to the next, each user is given 
the impression that he/she has his/her own CPU, whereas actually one CPU is being shared 
among many users. 

7.Multiprogramming Operating Systems 

Sharing the processor, when two or more programs reside in memory at the same time, is referred 
as multiprogramming. Multiprogramming assumes a single shared processor. Multiprogramming 
increases CPU utilization by organizing jobs so that the CPU always has one to execute. 

The following figure shows the memory layout for a multiprogramming system. 



 

An OS does the following activities related to multiprogramming. 

 The operating system keeps several jobs in memory at a time. 

 This set of jobs is a subset of the jobs kept in the job pool. 

 The operating system picks and begins to execute one of the jobs in the memory. 

 Multiprogramming operating systems monitor the state of all active programs and system 
resources using memory management programs to ensures that the CPU is never idle, 
unless there are no jobs to process. 

Advantages 

 High and efficient CPU utilization. 

 User feels that many programs are allotted CPU almost simultaneously. 

Disadvantages 

 CPU scheduling is required. 

 To accommodate many jobs in memory, memory management is required.  

8.Single user operating 

Single user operating system is also known as “Single Tasking Operating System”, and single 

user operating system is designed specially for using on the home computers. 

 Single user operating system allows the permission for accessing your personal computer at a 

time by single user, but some time it can support multiple profile. Single user operating system 

is used in the officially work and other environment as well. So, this operating system is not 

required for supporting the memory protection, file protection, and system security as well. 



 Single user operating system can be classified into two parts like as: 
 Single-User Single-Tasking operating system 
 Single-User Multi-Tasking operating system 
 

 Single-User Single-Tasking OS 

In the Single-User Single-Tasking operating system, only one user in permitted for performing single 

task at a time. This operating system is designed specially for wireless phone as well as two way 

messaging devices. some functions such as print a document, downloading images and video are 

performed one given frame time. 

Examples O/S are – MS-DOS, Palm OS, etc. 

 
 Single-User Multi-Tasking OS 

Single-User Multi-Tasking operating system is developed specially for one user, but this single user 

is able to perform to multiple tasks run at a same time frame. Some examples such as you can write 

any text, while surfing internet and downloading images with watching movies, etc. 

Example O/S are – Windows, Linux, Mac O/S 

 

Advantages: 
 Time saving. 
 High productivity in less time frame. 
 Less memory is used for performing multiple tasks. 

Disadvantages: 
 Require more space. 
 It has more complexity. 

 
9.Mobile OS 
Mobile operating systems are those OS which is especially that are designed to power 
smartphones, tablets, and wearables devices. 

Some most famous mobile operating systems are Android and iOS, but others include BlackBerry, 
Web, and watchOS. 

 
 
 
 
 
 
 
 
 
 



Difference between windows and DOS 
 

 DOS Windows 

Definition DOS (Disk Operating System) 
are simple text command 
operating systems that were 
popular from  1981 to 1995. 

Windows is a range of graphical 
interface operating systems that are 
developed and sold by Microsoft. 

GUI DOS used a text based interface 
that 

Windows uses graphics, images and 
text. 

 required text and codes to 
operate 

 

Input System Text is used as the basic input 
system commands. 

Uses a mouse for all operating system 
input. 

Multitasking DOS is unable to
 run multiple processes at 
the same time. 

Windows is a multitasking operating 
system; allowing more than one process 
to work simultaneously. 

Storage Size The highest amount of storage 
size available is 2GB. 

Window systems offer storage space up 
to 2 terabyte. 

Demands
 on 
System 
Resources 

Booting up system is DOS is less 
demanding on the CPU. 

Booting up Windows is more demanding 
on the CPU. 

Registry
 and 
Swap Files 

DOS uses a directory system, 
where all the files are contained 
within a particular directory or a 
subdirectory. 

Windows uses a different registry 
compared to DOS, making it difficult to 
manually delete programs. An 
excessive number of temporary files 
and file fragments can cause the system 
to slow down or crash. 

Current Uses More ideally used for prototyping, 
testing, and making automated 
systems. 

Used worldwide as the most popular 
operating system. 

Price DOS is free Windows is costly 

Computers have changed a great deal since the introduction of the first version of MS-DOS in 
1981. While MS-DOS was the dominant operating system in the world of computers for several 
years, graphical user interfaces (GUIs) eventually became the norm, and today Windows runs 
on the majority of the world's computers. Comparing standalone versions of MS-DOS with 
modern versions of  Windows you will find that, apart from the fact that Windows still has a 
command prompt available, the two operating systems have very little in common. 
Text vs. Graphics 

The primary way that an MS-DOS computer displays information is through plain text. Although 
many MS-DOS applications do have graphics, basic operating system tasks such as browsing 
and copying files take place entirely in text unless a graphical shell (a program that runs on top 
of the MS-DOS operating system) is used. In Windows, all operating system tasks take place 
within a graphical environment. Small pictures called "icons" represent each file and program. 
Early Windows versions are, in fact, graphical shells for MS-DOS. It was not until the release of 
Windows XP in 2001 that most home computer owners moved completely away from MS-DOS-
based operating systems. 



Input System 
MS-DOS uses text for all basic operating system commands. For example, the command 
"dir" lists the files in a directory, while the command "cd" navigates to a different directory. 
Windows uses a mouse for all operating system input except tasks that explicitly require 
text, such as creating a document or responding to email. 

 
Multitasking 

Windows is a multitasking operating system, meaning that it can run multiple program 
processes simultaneously. A typical Windows session might consist of the user browsing 
the Web while adding music to an MP3 player with their email program checking for new 
messages in the background. MS-DOS is unable to run multiple tasks simultaneously. 
When you want to do something else on an MS-DOS computer, you need to quit the 
current program and run a different one. 
 
Storage Size 
Hard drives manufactured today contain hundreds—and even thousands—of gigabytes of 
storage space. However, the final standalone version of MS-DOS, DOS 6.22, used the 
now-obsolete FAT16 file system. The maximum partition size that FAT16 supports is just 2 
GB. Today, 2 GB is a very small amount of storage, with memory cards the size of 
fingernails easily storing that amount. 

 
Introduction to DOS / WINDOWS 

Though UNIX was a powerful operating system available, but it was not suitable for 8-bit 
8086 microprocessor based Personal Computers. So there was a need for a small 
operating system that could work in 640K memory(RAM). DOS was an variant of CP/M 
(Control Program/Monitor) which ran for the first time on IBM-PC in 1981. It is called so 
because it resides on Floppy or Hard disk and provides command level interface between 
user and the computer hardware. The different versions of MS-DOS have evolved over a 
period of time with Microsoft introducing new features in each new releases. Starting with 
MS-DOS1.1, the latest version was MS-DOS6.22 released in 1994. There are various 
versions of DOS like MS-DOS(Microsoft), PC-DOS(IBM), Apple DOS, Dr-DOS etc. 
WINDOWS was similar to APPLE Mach operating system interface on IBM-PC. The main 
features of windows are easy to use graphical user interface (GUI), device independent 
graphics and multitasking support. The first version of windows1.0 was introduced in 1985. 
Windows was an application of MS- DOS using the basic commands of DOS. Windows for 
Workgroup (WIN3.11) released in 1992 was an integrated windows and networking 
package with file and printer sharing capabilities, a network mail (Microsoft Mail) and a 
workgroup scheduler (Schedule+) packages in windows environment. WINDOWS-95 
released in 1995 is a 32-bit operating system which includes MS-DOS7.0 and takes control 
of computer system after starting. 

 



                                                                                  

MS-DOS 
MS-DOS was the original operating system for (IBM) PC's, and served as the base on top of 
which Windows was originally written. MS-DOS provided a text-based 'command-line 
interface' instead of the visual interface of the Mac and Windows. 
Some knowledge of this command-line interface is still valuable for running older (MS-DOS) 
programs, and for writing 'scripts' ... sequences of operating system commands (also called 
batch or .BAT files). 

 
The structure of Disk Operating System for IBM PC-compatible computers can be broken 
down into four distinct components: 

 BIOS Module
 Kernel
 Command Processor
 External Commands

 
The operating system responsible for operating the disk is known as disk operating system 
or DOS. DOS helps in execution of all programs present in computer system. It can be 
operated upon by a single user operating system. DOS works to control all activities of the 
computer like deciding locations for the programs to be loaded, transferring files from hard 
disk to memory, accepting data from the keyboard, displaying information on the screen, 
handling printing tasks and so on. 

 

File names and directory structure 
A DOS file can have an 8 character name + an optional 3 character extension. The extension is 
intended to indicate the 'type' of the file. Most DOS and Windows programs assume some 
particular extension  for the file they use; Windows uses the extension to associate a 
particular program with a file. 

 
The files are organized in a tree-structured directory. An arbitrary file is specified by a path, 

device:\directory\directory\...\filename.ext 
 

The special file name '.' refers to the current directory; the file name '..' refers to the parent 
directory. Long Windows file names, and file names containing blanks or certain special 
characters, are mapped into MS-DOS file names of the form cccccc~1, cccccc~2, etc. They 
can also be referenced using the full file name inside of double-quote marks ("). 

 
History and versions of DOS :- 
1981 Microsoft buys the rights for QDOS from Seattle Computer Products (SCP) for $25,000 on 27’July. 
1981 MS-DOS 1.0 was released August, 1981. 
1982 MS-DOS 1.25 was released August, 1982. 
1983 MS-DOS 2.0 was released March, 1983. 
1984 Microsoft introduces MS-DOS 3.0 for the IBM PC AT and MS-DOS 3.1 for networks. 
1986 MS-DOS 3.2 was released April, 1986. 
1987 MS-DOS 3.3 was released April, 1987. 
1988 MS-DOS 4.0 was released July, 1988. 
1988 MS-DOS 4.01 was released November, 1988. 
1991 MS-DOS 5.0 was released June, 1991. 
1993 MS-DOS 6.0 was released August, 1993. 
1993 MS-DOS 6.2 was released November, 1993 
1994 MS-DOS 6.21 was released March, 1994 
1994 MS-DOS 6.22 was released April, 1994 



Types of DOS: 

There are two types of DOS:- 
 MS-DOS
 PC-DOS

 
Functions of DOS:- 

 It interact with the software or various application programs
 It provides file management utilities that perform useful tasks:-
1. Disk preparation 
2. File operations 
 It helps to automate the repetitive tasks.
 It co-ordinates with the functions of computer system

 It controls the execution of the program instruction
 It controls the way certain information is displayed on the screen

 It control the way your computer interprets certain command
 

BOOTING process:- 
When the computer is switched on, the firmware program in Read Only Memory(ROM) also called  
Basic Input-Output System(BIOS) reads programs and data i.e. Operating System and loads it into 
memory (RAM). This process is known Bootstrapping(Booting). The OS once loaded takes control of  
the computer, handles user interaction and executes application programs. 
During Booting process, computer loads the operating system into its memory. DOS booting involves 
reading following files into memory namely IO.SYS, MSDOS.SYS, and COMMAND COM. The Basic 
Input/Output Program (IO.SYS): This program provides interface between the hardware devices and 
software of the system. It takes care of the keyboard input, character output to monitor, output to 
printer and time of the day. 

The File and Disk Manager Program (MSDOS.SYS) : It contains the file management and the disk 
buffering management capabilities. It keeps track of all the disk access of an application program and 
remains permanently in memory. 

 
The Command Processor (COMMAND.COM) : It is also called command interpreter. It is the program 
that displays the system prompt and handles user interface by executing the command typed in by the 
user using keyboard. 



 

DOS commands:- 
Any instruction given to the computer to perform a specific task is called command. The DOS has 
several commands, each for a particular task and these are stored in DOS directory on the disk. The 
commands are of two types : (a)Internal Commands : These are in built commands of MS-DOS i.e. these 
are stored in Command interpreter file (COMMAND.COM). These commands reside in the memory as 
long as the machine is at he system prompt(C:\>) level. To use these commands no extra /external file 
is required. E.g. DATE, TIME, DIR, VER etc. (b) External commands : These are separate program (.com) 
files that reside in DOS directory and when executed behave like commands. An external command has 
predefined syntax. for e.g. HELP, DOSKEY, BACKUP, RESTORE, FORMAT etc. 

 
Internal Commands:- 

 DIR command:- Display the list of files and directories.
 MD or MKDIR command:- To make or create a new directory in the disk.
 CD or CHDIR command:- To switch from one directory to another.
 RD or RMDIR command:- To go inside the particular directory
 COPY command:- To copy one or specified files from one disk to another
 DEL command:- To delete any file present on the disk
 REN command:- To change the name of one or more files
 VOL command:- Display Disk Volume Label and volume serial number.
 DATE command:- It will display the system’s current date
 TIME command:-It will show current time of the system

 CLS command:- To clear screen
 PATH command:- Displays or sets a search path for executable files
 TYPE command: - Displays the contents of standard text files on the screen

 
External Commands:- 

 CHKDSK commands:- To check the status of a selected disk.
 XCOPY command:- Used to copy files and directory except system and hidden files.
 PRINT command:- To print one or more files.
 DISKCOPY command:- To make an exact duplicate of the original disk.
 DISKCOMP command:- To compare the content of two floppy disks to ensure they are identical.
 DOSKEY command:- Stores all DOS commands typed from the DOS prompt into thememory.
 TREE command:- Displays all the directory pathnames on the specified disk.

 MOVE command:- To move a directory ane one or more files from one location to another on 
the same disk.

 LABEL command:- To create, change or delete a volume label so as to identify adisk.
 APPEND command:- Allows to find files even when they are not in its owndirectory.
 FORMAT command:- To create a new root directory and file allocation table for the disk.

 
 

 

 

 



 

 

                                                          MS Windows 
 

Windows   XP is   a personal   computer operating   system produced   by Microsoft as   

part   of    the Windows NT family of operating systems. The operating system was 

released to manufacturing on August 24, 2001, and generally released for retail sale on 

October 25, 2001.Windows XP is a graphical user interface (GUI). It has pictures 

(graphical) that you use (user) to communicate (interface) with the computer. This type of 

system is popular because it's logical, fun, and easy to use.This operating system has 

multi-tasking capabilities, meaning it can run several applications at the same time. Multi-

tasking allows you to view this lesson on the Internet at the same time you practice using 

other applications with Windows XP. 

History of Windows: 

Versions Year 

Windows 10 Nov.1983 

Windows 1.0 Nov.1985 

Windows 2.0 09 Dec.1987 

Windows 3.0 22 May.1990 

Windows 95 August 1995 

Windows 98 June 1998 

Windows 2000 Feb.2000 

Windows XP 25 Oct. 2001 

Windows Vista 2007 

Windows 7 22 July 2009 

Windows 8 26 Oct. 2012 

 
The New and updated features in the new program are: 

 Windows XP is faster, smarter, safer 

 Windows XP is easier to learn and use 
 Windows XP offers better help for 

every task 

 Playing music, video and CDs 

 Offers wizard 

 User interface 

 Infrastructure 

 Networking and internet functionality 

 

Windows XP editions 
 Home and Professional 
 Starter Edition 
 Media Center Edition 
 Tablet PC Edition 
 Subscription and pre-paid editions 
 64-bit editions 
 Editions for embedded systems 
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Windows XP is an operating system 

Windows XP is a collection of programs, which enables the entire pc to work. Among 
Windows’ most important tasks are: 

o Assist in starting the pc. 

o Control and handling of all hardware, including RAM, I/O, cards and controllers. 

o Read-in of a graphics user interface with windows, menu bars etc. 
o Forms a platform for the user programs (applications) like Word, Internet 

Explorer, and Photoshop etc. 
o Handling of user data in files. 

 
Beyond the pure operating system tasks Windows XP includes a large collection of smaller 

and larger tools. Among others Windows XP comes with Internet Explorer and the 

multimedia player Windows Media Player, which are independent user programs. 

 
 
 
 
 
 
 
 
 
 

 
Windows XP is both an operating system and a program package. 

 
Desktop 

Desktops in a Windows is utility that allows users to manage applications on up to four 

virtual desktops, all accessible using the tray icon interface. 4. When referring to an 

operating system or GUI, the Desktop is a system of organization of icons on a screen. The 

Microsoft Windows Desktop was first introduced with Microsoft Windows 95 and has been 

included with every version of Windows since then. 
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The desktop contains: 
o Start button: This is one of the most important tools you will use while working with 

Windows XP. The Start button allows you to open menus and start applications. 
o Taskbar: This is primarily used to switch between open windows and applications. 

Learn more about using the taskbar in a later lesson. 
o Icons (or graphical pictures): This represents applications, files, and other parts of 

the operating system. By default, Windows XP provides you with one desktop icon, 
the Recycle Bin. 

o Windows Notification Area 

o Time and Date: The date and time is also shown on the Desktop, in the notification 

area on the taskbar. If the date and time is incorrect, you can change the date and 
time right from the Desktop. 

 
 

 

 

 

 



 

30  

Exploring Windows Explorer 

Windows Explorer is a file management tool that lets you create, rename, and delete 

folders. It also allows you to copy, print, move, delete, rename, and manage files. 

To open Windows Explorer: 

1. Open My Documents. 
2. Click the Folders button on the Navigation toolbar. 

1. A list of folders opens in the left pane. To explore Windows Explore With Windows 
Explorer open, scroll until you see the Control Panel icon in the left pane. 

2. Click the Control Panel icon. The contents (of the Control Panel folder) display in 
the right pane. 

3. Practice viewing other folders in the list. 
4. To close Windows Explorer, click the small black X in the upper right of the list 

OR click the Folder button. 

 
The Taskbar 
The taskbar is the small blue bar you see at the bottom of your desktop. It  contains the 

Start  menu and the Quick Launch bar, which contains icons for Internet Explorer, 

Windows Media Player, and Show Desktop. Click an icon to open a program. Click Show 

Desktop to quickly view your desktop without closing any programs or windows. 

 
 
 

The box on the right is called the Notification Area. 

Microsoft also uses the Notification Area to remind                                                               

you when software updates are available for 

download. 

When you open or minimize a window or program, a rectangular button appears on the 

taskbar    that shows the name of the application. 
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        The Start menu 

When you click the Start button, the Start menu appears. The Start menu is your path to 

the applications on your computer. It contains two columns. The left side of the Start menu 

lists programs, while the right side allows access to common Windows folders (My 

Documents, for example). It also provides access to Help and Support, Search, and Run. 

If you select All Programs, a pop-up menu appears. Pop-up menus like this are called 

cascading menus. If a cascading menu is available, a small black triangle appears next 

to the name of the application or function. 

To explore the Start menu: 

1. Click the Start button. 
2. Move the mouse pointer to each option, and view the various cascading menus. 
3. Click (or roll your mouse pointer over) All Programs. 
4. Move the mouse pointer to the right, and view other cascading menus. 
5. To exit the menus, click outside the menu area or press Esc on your keyboard
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         The Recycle Bin 

The Recycle Bin is nothing more than a space on the hard disk reserved to store 

information that is deleted so that in the event of deleting a file or folder by mistake it is 

possible to retrieve it. By default the Recycle Bin restores files or folders to the place from 

where they were deleted. If, for example, a file is deleted from D:\my documents, when it 

is restored it will go to that folder. 

                              The Recycle Bin will maintain the deleted documents until it is emptied. 

                              To  open  the  Recycle  Bin  place   the   cursor on Desktop and   double-     

click  on   the Recycle  Bin icon. 

Restoring Files or Folders 
To restore all of the elements from the Recycle Bin click on the green arrow on the left side 

that  says restore all items. 

 
If we only want to restore some of the elements: 

1) Select the elements to be restored by clicking on them. If the elements are not in 
subsequent order, use the Ctrl key to select them or the Shift key if they are one below the 
other. 
2) Once selected, a dialog box will appear on the green arrow on the left that will say 
Restore this item or Restore the selected items. 
The selected files will return to where they were located before deletion. 

 
Deleting Files or Folders from the Recycle Bin 

Before deleting any element from the Recycle Bin you need to realize that once it is deleted 

it cannot be retrieved or restored. 

If you want to delete any file or folder from the Recycle Bin follow these steps: 

1) Select the Elements to be deleted. 

2) Click  on ; this will delete the selected elements. You can also  do  this  by  
pressing the Delete button. 

The selected files will disappear and cannot be restored. 

 
My Computer 

It is another tool you can use to manage files and folders. With this tool, you can create, 

rename and move folders and copy, print, move, delete and rename files. It also allows 

you to gain access to other system tools. 
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To open My Computer: 

1. Double-click the My Computer icon on the desktop. 
2. My Computer opens. 

 
My Network Places overview 
My Network Places displays shortcuts to shared computers, printers, and other resources 

on the network. The shortcuts are created automatically in My Network Places whenever 

you open a shared network resource, such as a printer or shared folder. 

            Open My Network Places 

 To open My Network Places, click Start, and then click My Computer. Under Other 
Places, click My Network Places. 

 The View workgroup computers task is displayed in My Network Places when your 
computer is in a workgroup and not in a domain. Double-click this icon to narrow 
your search to only those computers, printers, and resources that share a workgroup 
with your computer. 

 If your computer is connected to a workgroup that has less than 32 computers, 
Windows will automatically create shortcuts in My Network Places to the shared 
resources in your workgroup. 

 To add a shortcut in My Network Places to a folder on a Web server, the Web server 
must support network places.. 

 
My Documents 

The My Documents folder is your own personal folder in which you can store your 

documents, graphics, and other personal files. You can change the target if you want My 

Documents to point to a different folder location. 

 Change the Default Location of the My Documents Folder 

 To change the default location of the My Documents folder, follow these steps: 

 Click Start, and then point to My Documents. 

 Right-click My Documents and then click Properties. Click the Target tab. 

 
User Accounts 

To get at the settings for the User Accounts, click Start and then Control Panel. From 

the Control Panel, double click User Accounts. 

 We can create a new user account. 

 We can make the account as password protected. 

 Through admin we can even change the password. 
 

Windows XP Accessories Applications: 

 Calculator, 

 Notepad, 

 WordPad, 

 Paint
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A word processor is an electronic device or computer application software that performs word 

processing: the composition, editing, formatting and sometimes printing of any sort of written 

material. Word processing can also refer to advanced shorthand techniques, sometimes used in 

specialized contexts with a specially modified typewriter. 

The word processor emerged as a stand-alone office machine in the 1970s and 1980s, combining the 

keyboard text-entry and printing functions of an electric typewriter with a dedicated computer 

processor for the editing of text. 

 

Characteristics 
 
Word processing typically implies the presence of text manipulation functions that extend beyond a 

basic ability to enter and change text, such as automatic generation of: 

 batch mailings using form letter template and an address database (also called mail merging); 

 indices of keywords and their page numbers; 

 tables of contents with section titles and their page numbers; 

 tables of figures with caption titles and their page numbers; 

 cross-referencing with section or page numbers; 

 footnote numbering; 

 New versions of a document using variables (e.g. model numbers, product names, etc.) 

 

Examples of different word processing software are: 

 

 WordPerfect 
 Microsoft Word 

 Word Mark 

 Lotus WordPro 

 Procedure Write 

 

Types of word processor:- 
 

 Dedicated word processor 
 Standard word processor software packages 

 Word processing packages on minicomputer 

 

Microsoft office Word:- 

 
Microsoft Office Button :- After clicking you get the Menu to create, open, save and perform 

other operations 

The Ribbon:- The Ribbon is the panel at the top portion of the document. It has seven tabs: Home, 

Insert, Page Layout, References, Mailings, Review, and View that contain many new and existing 

features of Word. 

Each of the tabs contains the following tools: 

Introduction to MS-Word 
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 Home: Clipboard, Fonts, Paragraph, Styles, and Editing. 

 Insert: Pages, Tables, Illustrations, Links, Header & Footer, Text, and Symbols 

 Page Layout: Themes, Page Setup, Page Background, Paragraph, Arrange 

  References: Table of Contents, Footnote, Citation & Bibliography, Captions, Index, and 
Table of Authorities 

 Mailings: Create, Start Mail Merge, Write & Insert Fields, Preview Results, Finish 

 Review: Proofing, Comments, Tracking, Changes, Compare, Protect 

 View: Document Views, Show/Hide, Zoom, Window, Macros 

 

Ruler: - Can use to change the format of your document quickly. 

Text area: - The area for writing the document is called Text Area. 

Status Bar: - appears at the very bottom of your window and provides the information about the 

current page and number of words in your document. 

Scroll Bar: - you have two types of scroll bar i.e. horizontal and vertical scroll bar to move the 

document. 
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Formatting Features of Ms Word:- 

 

 

 

 

 

 

 

 

 

 

 

 

The commonly used are as follows:- 

 Bold and italic 

 Underlined 

 Font style 

 Font size 

 

To format font size: 
 Select the text you wish to modify. 

 Left-click the drop-down arrow next to the font size box on the Home tab. The font 

size drop-down menu appears. 

 Move your cursor over the various font sizes. A live preview of the font size will 

appear in the document. 

 Left-click the font size you wish to use. The font size will change in the document. 

 

To format font style: 
 Select the text you wish to modify. 

 Left-click the drop-down arrow next to the font style box on the Home tab. The font 

style drop-down menu appears. 

 Move your cursor over the various font styles. A live preview of the font will appear in 

the document. 

 Left-click the font style you wish to use. The font style will change in the document. 

 

To format font color: 
 Select the text you wish to modify. 
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 Left-click the drop-down arrow next to the font color box on the Home tab. The font 

color menu appears. 

 Move your cursor over the various font colors. A live preview of the color will appear 

in the document. 

 Left-click the font color you wish to use. The font color will change in the document. 

 

 

To use the bold, italic, and underline commands: 
 Select the text you wish to modify. 

 Click the bold, italic, or underline command in the Font group on the Home tab. 

 

To change the text case: 
 Select the text you wish to modify. 

 Click the Change Case command in the Font group on the Home tab. 

 Select one of the case options from the list. 

 

To change text alignment: 
 Select the text you wish to modify. 

 Select one of the four alignment options from the Paragraph group on the Home tab. 

o Align Text Left: Aligns all of the selected text to the left margin. 

o Center: Aligns text an equal distance from the left and right margins. 

o Align Text Right: Aligns all of the selected text to the right margin. 
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To format font size: 
 Select the text you wish to modify.

 Left-click the drop-down arrow next to the font size box on the Home tab. The font size 

drop-down menu appears.

 Move your cursor over the various font sizes. A live preview of the font size will appear in 

the document.

 Left-click the font size you wish to use. The font size will change in the document.

 

To format font style: 
 Select the text you wish to modify.
 Left-click the drop-down arrow next to the font style box on the Home tab. The font style 

drop-down menu appears.

 Move your cursor over the various font styles. A live preview of the font will appear in the 

document.

 Left-click the font style you wish to use. The font style will change in the document.

 
To format font color: 

 Select the text you wish to modify.
 Left-click the drop-down arrow next to the font color box on the Home tab. The font color 

menu appears.

 Move your cursor over the various font colors. A live preview of the color will appear in the 

document.

Left-click the font color you To format font size: 
 Select the text you wish to modify.

 Left-click the drop-down arrow next to the font size box on the Home tab. The font size 

drop-down menu appears.

 Move your cursor over the various font sizes. A live preview of the font size will appear in 

the document.

 Left-click the font size you wish to use. The font size will change in the document.

 

To format font style: 
 Select the text you wish to modify.
 Left-click the drop-down arrow next to the font style box on the Home tab. The font style 

drop-down menu appears.

 Move your cursor over the various font styles. A live preview of the font will appear in the 

document.

 Left-click the font style you wish to use. The font style will change in the document.

 

To format font color: 
 Select the text you wish to modify.
 Left-click the drop-down arrow next to the font color box on the Home tab. The font color 

menu appears.

 Move your cursor over the various font colors. A live preview of the color will appear in the 

document.

 Left-click the font color you wish to use. The font color will change in the document.
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To use the bold, italic, and underline commands: 
 Select the text you wish to modify.

 Click the bold, italic, or underline command in the Font group on the Home tab.

 

To change the text case: 
 Select the text you wish to modify.

 Click the Change Case command in the Font group on the Home tab.

 Select one of the case options from the list.

 

To change text alignment: 
 Select the text you wish to modify.
 Select one of the four alignment options from the Paragraph group on the Home tab.

o Align Text Left: Aligns all of the selected text to the left margin. 

o Center: Aligns text an equal distance from the left and right margins. 

o Align Text Right: Aligns all of the selected text to the right margin. 

 wish to use. The font color will change in the document.

 

To use the bold, italic, and underline commands: 
 Select the text you wish to modify.

 Click the bold, italic, or underline command in the Font group on the Home tab.

 

To change the text case: 
 Select the text you wish to modify.

 Click the Change Case command in the Font group on the Home tab.

 Select one of the case options from the list.

 

To change text alignment: 

o Select the text you wish to Justify: Justified text is equal on both sides and lines up 
equally to the right and left margins. Traditionally, many books, newsletters, and 
newspapers use full justification. 

 

Working with text:- 

To insert 

text: 

 Move your mouse to the location you wish text to appear in the document.
 Left-click the mouse. The insertion point appears.

 Type the text you wish to appear.

 

To delete text: 
 Place your cursor next to the text you wish to delete.
 Press the Backspace key on your keyboard to delete text to the left of the cursor.

 Press the Delete key on your keyboard to delete text to the right of the cursor.

 

To select text: 
 Place the insertion point next to the text you wish to select.
 Left-click your mouse and while holding it down, drag your mouse over the text to select it.
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 Release the mouse button. You have selected the text. A highlighted box will appear over the 

selected text.

When you select text or images in Word, a hover toolbar with formatting options appears. This 

makes formatting commands easily accessible, which can save you time. 

 

To copy and paste text: 
 Select the text you wish to copy.
 Click the Copy command on the Home tab.

 Place your insertion point where you wish the text to appear.

 Click the Paste command on the Home tab. The text will appear.

 

 

 

 

 

 
To drag and drop text: 

 Select the text you wish to copy.
 Left-click your mouse, and drag the text to the location you wish it to appear. The cursor will 

have a text box underneath it to indicate that you are moving text.
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Word Art

Word Art are styles that can be applied to text to create a visual effect. To apply Word Art:- 

 Select text

 Click insert tab

 Click word Art

 Choose the Word Art

 Select the Word Art

 Click the format tab from the drawing 
tools

 Click Word Art button
 

 

 

Working with Header, Footers and Footnotes 

 
The header is a section of the document that appears in the top margin, while the footer is a section 

of the document that appears in the bottom margin. Headers and footers generally contain 

information such as page number, date, and document name. 

Header: - Header consists of text and graphics appears at the top of every page of a document. 

Footers: - Footers appears at the bottom of every page in the same document. 

For e.g.: - you can date page number, the time and date, a company logo, the document title. 

 

Steps to insert header and footers:- 

There are different options to inset header and footer they are as follows:- 

 Insert the same header or footer on each page

 Insert predefined header and footer 
 Insert custom header and footer 

 Make the first page header or footer different from the rest of the pages.

 Make the header or footer different for odd and even pages.
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 Make the header or footer different in each section or chapter

 Use documents section breaks to vary the header or footer.

 Use the same header or footer across section boundaries

 Change the contents of a header or footer

 Insert a page number

 

To insert a header or footer: 
 Select the Insert tab.

 Click either the Header or Footer command. A menu appears with a list of built-in 

options you can use.
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 Left-click one of the built-in options, and it will appear in the document.

 

OR 

 Left-click Blank to select it.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 The Design tab with Header and Footer tools is active.

 

 

 

 

 

 
 

 Type information into the header or footer.
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To insert the date or time into a header or footer: 

 With the header or footer section active, click the Date & Time command.
 

 

 

 

 

 

 

 

 

 

 

 

 

 
 Select a date format in the dialog box that appears.

 Click OK. The date and time now appear in the document.

 

Other header and footer options 
There are many other header and footer options you can use to design these sections of your 

document. From the Header and Footer Tools Design tab, you can see all of your design options. 

 

Footnotes and end notes:- 
 A footnote or an endnote consists of two linked parts — the note reference mark (note 

reference mark: A number, character, or combination of characters that indicates that 
additional information is contained in a footnote or endnote.) and the corresponding note text.

 When you add, delete, or move notes that are automatically numbered, Word renumbers the 
footnote and endnote reference marks.

 

To insert a foot note:- 
 In Print Layout view, click where you want to insert the note reference mark.

 On the References tab, in the Footnotes group, click Insert Footnote or Insert Endnote.

 To make changes to the format of footnotes or endnotes, click the Footnotes Dialog Box 

Launcher, and do one of the following:

 In the Number format box, click the format that you want.

 To use a custom mark instead of a traditional number format, click Symbol next to Custom 
mark, and then choose a mark from the available symbols.

 Click Insert.

 Type the note text.

 Double-click the footnote or endnote number to return to the reference mark in the document.
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Adding SmartArt: 
 Click insert tab

 Click Smart Art button

 Choose the Smart art 

  Click the Smart Art. 

 Drag it to the desired location in document 
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Using Borders in  Word 

 

Borders can be applied to: 

  Paragraphs 

  Selected text 

  Tables and table cells 

  Pages 

1 

Place your cursor on the page that needs the border. 

2 

Click "Page Layout" in the Word ribbon, then click "Breaks" from the Page Setup group. 

3 

Click "Next Page" in the Section Breaks pane of the drop-down menu. 

4 

Move the cursor to the previous page. For example, to add the border to page 4, place the cursor in 
page 3. 

5 

Repeat Steps 2 and 3 to add a second section break. 

6 

Return to the page that needs the border. Click "Page Borders" in the Page Background group on the 
ribbon to open the Borders and Shading dialog box. 

7 

Choose your border. For example, click the dotted border style, set the color to red and set the width to 
1.5 points. 
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8 

Click the "Apply to" box and select "This Section" from the drop-down menu. 

9 

Click "OK" to apply the border. 
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Mail Merge 
 

Mail Merge is used to create and print letters and other documents, such as a form letter that is 

sent to many customers. Each letter has the same kind of information, yet the content is 

unique. For example, in letters to your customers, each letter can be personalized to address 

each customer by name. The unique information in each letter comes from entries in a data 

source. 

The mail merge process entails the following overall steps: 

 Set up the main document: - The main document contains the text and graphics that 

are the same for each version of the merged document — for example, the return 

address or salutation in a form letter.

 Connect the document to a data source:-A data source is a file that contains the 
information to be merged into a document. For example, the names and addresses of 

the recipients of a letter.

 Refine the list of recipients or items. Microsoft Office Word generates a copy of the 

main document for each item, or record, in your data file. If your data file is a mailing 

list, these items are probably recipients of your mailing. If you want to generate copies 

for only certain items in your data file, you can choose which items (records) to 

include.

 Add placeholders, called mail merge fields, to the document. When you perform the 
mail merge, the mail merge fields are filled with information from your data file.

 Preview and complete the merge. You can preview each copy of the document before 
you print the whole set.

 You use commands on the Mailings tab to perform a mail merge.

You can also perform a mail merge by using the Mail Merge task pane, which leads you step 

by step through the process. To use the task pane, in the Start Mail Merge group on the 

Mailings tab, click Start Mail Merge, and then click Step by Step Mail Merge Wizard. 

Steps 1-3 

 Choose the type of document you wish to create. In this example, select Letters.

 Click Next: Starting document to move to Step 2.

 Select Use the current document.

 Click Next: Select recipients to move to Step 3.

 Select the Type a new list button.

 Click Create to create a data source. The New Address List dialog box appears.
o Click Customize in the dialog box. The Customize Address List dialog box 

appears. 

o Select any field you do not need and click Delete. 

o Click yes to confirm that you wish to delete the field. 

o Continue to delete any unnecessary fields. 

o Click Add. The Add Field dialog box appears. 

o Enter the new field name. 

o Click OK. 
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o Continue to add any fields necessary. 

o Click OK to close the Customize Address List dialog box. 
To Customize the New Address List: 

 Enter the necessary data in the New Address List dialog box.

 Click New Entry to enter another record.

 Click Close when you have entered all your data records.

 Enter the file name you wish to save the data list as.

 Choose the location you wish to save the file.

 Click Save. The Mail Merge Recipients dialog box appears and displays all 

the data records in the list.

 Confirm the data list is correct and click OK.

 Click Next: Write your letter to move to Step 4.

 
Steps 4-6 

 Write a letter in the current Word document, or use an open, existing 

document. To Insert Recipient Data from the List:

o Place the insertion point in the document where you wish the information 

to appear. 
o Select Address block, Greeting line, or Electronic postage from the task 

pane. A dialog box with options will appear based on your selection. 

OR 

o Select More Items. The Insert Merge Field dialog box will appear. 

o Select the field you would like to insert in the document. 
o Click Insert. Notice that a placeholder appears where information from 

the data record will eventually appear. 

o Repeat these steps each time you need to enter information from your data 

record. 

 Click Next: Preview your letters in the task pane once you have completed 
your letter.

 Preview the letters to make sure the information from the data record 

appears correctly in the letter.

 Click Next: Complete the merge.

 Click Print to print the letters.

 Click All.

 Click OK in the Merge to Printer dialog box.

 Click OK to send the letters to the printer.

 

The Mail Merge wizard allows you to complete the mail merge process in a variety of 

ways. 
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Important link for MS WORD 
 

 

 

 

 
 

https://youtu.be/ME_F9yypzsw 

https://youtu.be/B54cm8TWTjI 

https://youtu.be/iCxm0RZG4Fk 
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Excel Basics:-

Excel 2007 is the spreadsheet software in the Microsoft 2007 Office Suite. It allows you to store, 
organize, and analyze numerical and text data Ribbons

Located where taskbars used to be, ribbons graphically display the changing features as you click
on the menu-bar tabs. It may be take you time to adjust to the new locations of familiar options,
but ribbons may expose you to new commands and tools.

The Ribbon provides you the below tabs:-
 Home:- Change the Font, Paragraph and Heading styles and view the clipboard and 

editing options
 Insert:- Insert pages, tables, illustrations, links, headers, footers, text and symbols

 Page Layout:- Alter page setup, background, themes, paragraph properties, and 
arrangement of document

 Formulas:- Insert functions and create custom formulas.

 Data:- Get external data, sort, filter, and outline existing.
 Review:- Use proofing techniques, insert comments, track changes, compare and protect 

documents

 View:- Change document and window layout, show/hide thumbnails, and view/record 
macros

 Add-Ins:- Customize toolbars

Above the Ribbon in the upper-left corner is the Microsoft Office Button. From here, you can
access important options such as New, Save, Save As, and Print. By default, the Quick Access
Toolbar is pinned next to the Microsoft Office Button and includes commands such as Undo and
Redo.

At  the  bottom-left  area  of  the  spreadsheet,  you  will  find  worksheet  tabs.  By  default,  three
worksheet tabs appear each time you create a new workbook. On the bottom-right area of the
spreadsheet you will find page view commands, the zoom tool, and the horizontal scrolling bar.

To change page views:

 Locate the Page View options in the bottom-right corner. The Page View options are 

MS Excel 2007
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Normal, Page Layout, and Page Break.
 Left-click an option to select it.

“The default is Normal View.”
To add commands to the Quick Access Toolbar:

 Click the arrow to the right of the Quick Access Toolbar.
 Select the command you wish to add from the drop-down list. It will appear in the Quick 

Access Toolbar.
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Spreadsheets and Workbooks
A spreadsheet is a grid of data divided into numbered rows and lettered columns. Each block in
this  grid  is  called  a  cell,  and  it  can  hold  an  individual  piece  of  text  or  data.  In  Excel,  a
file/document is considered a spreadsheet, although it is commonly referred to as a workbook.

Worksheets
The worksheet is a page of data in your spreadsheet (or workbook) that is organized by the 
labeled tabs displayed at the bottom of the Excel window.
• Your spreadsheet can contain as many worksheets as you want. By default, however, all newly 
opened Excel spreadsheets have three worksheets.
• To view the contents of a worksheet, click on its tab.

Cell 
 In Microsoft Excel, a cell is a rectangular box that occurs at the intersection of a vertical    column  and a

horizontal row in a worksheet. Vertical columns are numbered with alphabetic values such as A, B, C.
Horizontal rows are numbered with numeric values such as 1, 2, 3.

Each cell has its own set of coordinates or position in the worksheet such as A1, A2, or M16. In
theexample above, we are positioned on cell A1 which is the intersection of column A and row 1.

   A cell can only store 1 piece of data at a time. You can store data in a cell such as a formula, text value,
numeric value, or date value.

There are many things that you can do with cells in Excel such as changing the font format, number 
format, background, alignment, and conditional formatting. Here is a list of topics that explain how to use 
cells in Excel.

 Active cell          
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The Active cell inside Excel Worksheet is used to identify the cell which is currently active. The 
thick border gridlines around the cell indicates that it is the Active cell inside Excel Worksheet. The Active 
cell is where the focus is on and where the data will be entered when a key is typed on keyboard. Below 
image shows the Actice Cell as C5, which is hi-lighted with a thick border.

       

Row and Column Basics
     MS Excel is in tabular format consisting of rows and columns.

 Row runs horizontally while Column runs vertically.

 Each row is identified by row number, which runs vertically at the left side of the sheet.
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 Each column is identified by column header, which runs horizontally at the top of the sheet.

   For MS Excel 2010, Row numbers ranges from 1 to 1048576; in total 1048576 rows, and Columns     
ranges from A to XFD; in total 16384 columns.

Navigation with Rows and Columns
Let us see how to move to the last row or the last column.

 You can go to the last row by clicking Control + Down Navigation arrow.

 You can go to the last column by clicking Control + Right Navigation arrow.

              

Cell Reference
A cell reference is a set of coordinates that identifies a specific cell . it is a combination of letters 
and numbers.
Cell Range- A cell range is a collection of cell that have been identified  as a group based on a 
variety  of criteria . By  using a colon ( : )  between cell reference ,excel can determine the 
range .also known as an array.



Devi Ahilya Arts & Commerce College , Indore

Create a workbook
                                                  Open Excel.

                              Select Blank workbook or press Ctrl+N. 
                                                   
 
                                                    Start typing.

To save the workbook:
 Left-click the Microsoft Office button.

 Select Save or Save As.

o Save As allows you to name the file and choose a location to 
save the spreadsheet. Choose Save As if you'd like to save the 
file for the first time or if you'd like to save the file as a different 
name.

o Select Save if the file has already been named.

Important link-   https://youtu.be/M6yGaPvJcuA

                          https://youtu.be/4UHCsQKmLHs
                           
                          https://youtu.be/1M-boE_JlNw
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Modifying Columns, Rows, and Cells

                                                   
When you open a new blank workbook, the cells, columns, and rows are set to a default size. You have 

the ability to change the size of each, as well as to insert new columns, rows, and cells as needed. In this 

lesson, you will learn various methods to modify the column width and row height, as well as how to 

insert new columns, rows, and cells.

 modify column width

 Position the cursor over the column line in the column heading, and a double arrow will appear.

 Left-click the mouse, then drag the cursor to the right to increase the column width or to 
the left to decrease the column width.

 Release the mouse button.
OR

 Left-click the column heading of a column you'd like to modify. The entire column will 
appear highlighted.
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 Click the Format command in the Cells group on the Home tab. A menu will appear.
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 Select Column Width to enter a specific column measurement.

 Select AutoFit Column Width to adjust the column so all of the text will fit.

If you see pound signs (#######) in a cell, it means that the column is not wide enough to display

the cell content. Simply increase the column width to show the cell content.

To modify the row height:

 Position the cursor over the row line you want to modify, and a double arrow will 
appear.
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 Left-click the mouse, then drag the cursor upward to decrease the row height 
or downward to increase the row height.

 Release the mouse button.  or

o Click the Format command in the Cells group on the Home tab. A menu will

o

 Select Row Height to enter a specific row measurement.

 Select AutoFit Row Height to adjust the row so all of the text will fit.

To insert rows

 Select the row below where you want the new row to appear.

 Click the Insert command in the Cells group on the Home tab. The row will appear.
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The new row always appears above the selected row.

Make sure you select the entire row below where you want the new row to appear and not just 

the cell. If you select just the cell and then click Insert, only a new cell will appear.

To insert columns:

 Select the column to the right of where you want the column to appear.

 Click the Insert command in the Cells group on the Home tab. The column will 
appear.

The new column always appears to the left of the selected column. For example, if you want to 

insert a column between September and October, select the October column, then click the Insert 

command.
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Make sure you select the entire column to the right of where you want the new column to appear 

and not just the cell. If you select just the cell and then click Insert, only a new cell will appear.

To delete rows and columns:

 Select the row or column you’d like to delete.

 Click the Delete command in the Cells group on the Home tab.

Formatting Text
  

                                                   
Once you have entered information into a spreadsheet, you will need to be able 
to format it. In this lesson, you will learn how to use the bold, italic, and underline 
commands; modify the font style, size, and color; and apply borders and fill colors.
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To format text in bold or italics:
 Left-click a cell to select it, or drag your cursor over the text in the 

formula bar to select it.

 Click the Bold or Italics command.

You can select entire columns and rows, or specific cells. To select the entire column, 
just left-click the column heading, and the entire column will appear as selected. To 
select specific cells, just left-click a cell and drag your mouse to select the other cells, 
then release the mouse button.

To format text as underlined:

 Select the cell or cells you want to format.

 Click the drop-down arrow next to the Underline command.

 Select the Single Underline or Double Underline option.

    Important Link-https://youtu.be/1M-boE_JlNw
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To change the font style:

 Select the cell or cells you want to format.

 Left-click the drop-down arrow next to the Font Style box on the
Home tab.

 Select a font style from the list.

As you move over the font list, the Live Preview feature previews the font for you 
in the spreadsheet.

To change the font size:

 Select the cell or cells you want to format.

 Left-click the drop-down arrow next to the Font Size box on the 
Home tab.
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Select a font size from the list.  

To change the text colour:

 Select the cell or cells you want to format.

 Left-click the drop-down arrow next to the Text 
Colour command. A colour palette will appear.

 Select a colour from the palette.

OR

 Select More Colours. A dialog box will appear.

 Select a colour.
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 Click OK.

To add a border:

 Select the cell or cells you want to format.

 Click the drop-down arrow next to the Borders command on the 
Home tab. A menu will appear with border options.

 Left-click an option from the list to select it.

You can change the line style and color of the border.

To add a fill colour:

 Select the cell or cells you want to format.

 Click the Fill command. A colour palette will appear.

 Select a colour.
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OR

 Select More Colours. A dialog box will appear.

 Select a colour.

 Click OK.

You can use the fill colour feature to format columns and rows and format a 
worksheet so it's easier to read.

To format numbers and dates:

 Select the cell or cells you want to format.

 Left-click the drop-down arrow next to the Number Format box.
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 Select one of the options for formatting numbers. 

Working with Cells

                                  
It is important to know how to move information from one cell to another in Excel. Learning the various 

ways will save you time and make working with Excel easier. Certain methods are more appropriate, 

depending on how much information you need to move and where it will reside on the spreadsheet. In this 

lesson, you will learn how to cut, copy, and paste, as well as how to drag and drop information.

To copy and paste cell contents:

 Select the cell or cells you wish to copy.

 Click the Copy command in the Clipboard group on the Home tab. 
The border of the selected cells will change appearance.
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 Select the cell or cells where you want to paste the information.

 Click the Paste command. The copied information will now appear 
in the new cells.

To select more than one adjoining cell, left-click one of the cells, drag the cursor until all of the cells are 

selected, and release the mouse button.
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The copied cell will stay selected until you perform your next task, or you can double-click the cell 

to deselect it.

To cut and paste cell contents:

 Select the cell or cells you wish to cut.

 Click the Cut command in the Clipboard group on the Home tab. 
The border of the selected cells will change appearance.

 Select the cell or cells where you want to paste the information.

 Click the Paste command. The cut information will be removed 
from the original cells and now appear in the new cells.
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The keyboard shortcut for Paste is the Control Key and the V key.

To drag and drop information:

 Select the cell or cells you wish to move.

 Position your mouse pointer near one of the outside edges of 
the selected cells. The mouse pointer changes from a large, white
cross to a black cross with four arrows.

 Left-click, then hold the mouse button and drag the cells to the 
new location.
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Release the mouse button, and the information appears in the new

location. 
Aligning Text

                               
Worksheets that have not been formatted are often difficult to read. Fortunately, Excel gives you many 

tools that allow you to format text and tables in various ways. One of the ways you can format your 

worksheet so it's easier to work with is to apply different types of alignment to text.

Aligning text

Excel 2007 left-aligns text (labels) and right-aligns numbers (values). This makes data easier to read, 

but you do not have to use these defaults. Text and numbers can be defined as left-aligned, right-aligned, 

or centered in Excel.
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To align text or numbers in a cell:
 Select a cell or range of cells.

 Click on either the Align Left, Center, or Align Right commands 
on the Home tab.

 The text or numbers in the cell(s) take on the selected alignment 
treatment.

Left-click a column label to select an entire column or a row label to select an entire 
row.

Changing vertical cell alignment

You can also define vertical alignment in a cell. In vertical alignment, information in a cell can be located

at the top of the cell, middle of the cell, or bottom of the cell. The default is bottom.

To change vertical alignment from the alignment group:

 Select a cell or range of cells.

 Click the Top Align, Center, or Bottom Align command.
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Changing text control

Text control allows you to control the way Excel 2007 presents information in a cell. There are two 

common types of text control: Wrapped text and merged cells.

Wrapped Text wraps the contents of a cell across several lines if it's too large than the column width. It 

increases the height of the cell as well.

Merge Cells can also be applied by using the Merge and Center button on the Home 
tab.

To change text control:

 Select a cell or range of cells.

 Select the Home tab.
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 Click the Wrap Text command or the Merge and 
Center command.

If you change your mind, click the drop-down arrow next to the command, then 
choose Unmerge cells.



Creating Simple Formulas

   Excel can be used to calculate and analyze numerical 
information; however, you will need to know how to 
write formulas to maximize Excel's capabilities. A 
formula is an equation that performs a calculation 
using values in the worksheet. In this lesson, you will 

learn how to create simple formulas using mathematical operators such as the 
addition, subtraction, multiplication, and division signs.

Simple formulas



Devi Ahilya Arts & Commerce College , Indore

To create a simple formula that adds two numbers:

 Click the cell where the formula will be defined (C5, for example).

 Type the equals sign (=) to let Excel know a formula is being 
defined.

 Type the first number to be added (e.g., 1500).

 Type the addition sign (+) to let Excel know that an add 
operation is to be performed.

 Type the second number to be added (e.g., 200).

 Press Enter, or click the Enter button on the Formula bar to 
complete the formula.

If the result of a formula is too large to be displayed in a cell, it may appear as pound signs (#######) 

instead of a value. This means that the column is not wide enough to display the cell content. 

Simply increase the column width to show the cell content.

To create a simple formula that adds the contents of two cells:

 Click the cell where the answer will appear (C5, for example).

 Type the equals sign (=) to let Excel know a formula is being 
defined.

 Type the cell number that contains the first number to be added 
(C3, for example).
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 Type the addition sign (+) to let Excel know that an add 
operation is to be performed.

 Type the cell address that contains the second number to be added
(C4, for example).

 Press Enter, or click the Enter button on the Formula bar to 
complete the formula.

To create a simple formula using the point-and-click method:

 Click the cell where the answer will appear (C30, for example).

 Type the equals sign (=) to let Excel know a formula is being 
defined.

 Click on the first cell to be included in the formula (C5, for 
example).

 Type the subtraction sign (-) to let Excel know that a subtraction 
operation is to be performed.

 Click on the next cell in the formula (C29, for example).
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 Press Enter, or click the Enter button on the Formula bar to 
complete the formula.

To create a simple formula that multiplies the contents of two cells:

 Select the cell where the answer will appear (E32, for example).

 Type the equals sign (=) to let Excel know a formula is being 
defined.

 Click on the first cell to be included in the formula (C9, for 
example), or type a number.

 Type the multiplication symbol (*) by pressing the Shift key and 
then the number 8 key. The operator displays in the cell and 
Formula bar.

 Click on the next cell in the formula or type a number (12, for 
example).
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 Press Enter, or click the Enter button on the Formula bar to 
complete the formula.

To create a simple formula that divides one cell by another:

 Click the cell where the answer will appear.

 Type the equals sign (=) to let Excel know a formula is being 
defined.

 Click on the first cell to be included in the formula.

 Type a division symbol. The operator displays in the cell and 
Formula bar.

 Click on the next cell in the formula.

 Press Enter, or click the Enter button on the Formula bar to 
complete the formula.

Using cell references

As you can see, there are many ways to create a simple formula in Excel. Most 
likely, you will choose one of the methods that enters the cell address into the 
formula rather than an actual number. The cell address is basically the name of 
the cell and can be found in the Name Box.
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The following example uses actual numbers in the formula in C5.

When a cell address is used as part of a formula, this is called a cell reference. It 
is called a cell reference because instead of entering specific numbers into a 
formula, the cell address refers to a specific cell. The following example uses cell
references in the formula in C30.
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Working with Basic Functions

                                                            

A function is a predefined formula that performs calculations using specific values in a particular order. 

While you may think of formulas as being short mathematical equations, like 2+2 or F2*C2, they can 

actually be very lengthy and involve complex mathematical calculations.

One of the key benefits of functions is that they can save you time because you do not have to write the 

formula yourself. For example, you could use an Excel function called Average to quickly find the 

average of a range of numbers or the Sum function to find the sum of a cell range.
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The parts of a function:

Each function has a specific order, called syntax, which must be strictly followed for the function to work 

correctly.

Syntax order:

1. All functions begin with the = sign.

2. After the = sign, define the function name (e.g., Sum).

3. Then there will be an argument. An argument is the cell range or 
cell references that are enclosed by parentheses. If there is more 
than one argument, separate each by a comma.

An example of a function with one argument that adds a range of cells, A3 through A9:

An example of a function with more than one argument that calculates the sum of two cell ranges:

Excel literally has hundreds of different functions to assist with your calculations. Building formulas can 

be difficult and time consuming. Excel's functions can save you a lot of time and headaches.
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Excel's different functions

There are many different functions in Excel 2007. Some of the more common 
functions include:

Statistical functions:

 SUM: Adds a range of cells together

 AVERAGE: Calculates the average of a range of cells

 COUNT: Counts the number of chosen data in a range of cells

 MAX: Identifies the largest number in a range of cells

 MIN: Identifies the smallest number in a range of cells

Financial functions:

 Interest rates

 Loan payments

 Depreciation amounts

Date and time functions:

 DATE: Converts a serial number to a day of the month

 Day of Week

 DAYS360: Calculates the number of days between two dates 
based on a 360-day year

 TIME: Returns the serial number of a particular time

 HOUR: Converts a serial number to an hour
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 MINUTE: Converts a serial number to a minute

 TODAY: Returns the serial number of today's date

 MONTH: Converts a serial number to a month

 YEAR: Converts a serial number to a year

To calculate the sum of a range of data using AutoSum:
 Select the Formulas tab.

 Locate the Function Library group. From here, you can access all 
available functions.

 Select the cell where you want the function to appear. In this 
example, select G42.

 Select the drop-down arrow next to the AutoSum command.

 Select Sum. A formula will appear in the selected cell, G42.

o This formula, =SUM(G2:G41), is called a function. The 
AutoSum command automatically selects the range of cells 
from G2 to G41, based on where you inserted the function. 
You can alter the cell range if necessary.
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 Press the Enter key or Enter button on the formula bar. The total
will appear.

To edit a function:

 Select the cell where the function is defined.

 Insert the cursor in the formula bar.

 Edit the range by deleting and changing necessary cell numbers.
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 Click the Enter icon.

To calculate the sum of two arguments:

 Select the cell where you want the function to appear—in this 
example, G44.

 Click the Insert Function command on the Formulas tab. A dialog 
box appears.

 SUM is selected by default.
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 Click OK, and the Function Arguments dialog box appears so you can enter the range of 
cells for the function.

 Insert the cursor in the Number 1 field.

 In the spreadsheet, select the first range of cells—in this example, G21 through G26. The 
argument appears in the Number 1 field.

o To select the cells, left-click cell G21 and drag the cursor to G26, then release 
the mouse button.

 Insert the cursor in the Number 2 field.
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 In the spreadsheet, select the second range of cells—in this 
example, G40 through G41. The argument appears in the Number 2
field.

 Notice that both arguments appear in the function in cell G44 and 
the formula bar when G44 is selected.

 Click OK in the dialog box, and the sum of the two ranges is 
calculated.
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To calculate the average of a range of data:

 Select the cell where you want the function to appear.

 Click the drop-down arrow next to the AutoSum command.

 Select Average.

 Click on the first cell (in this example, C8) to be included in the 
formula.

 Left-click and drag the mouse to define a cell range (C8 through 
cell C20, in this example).

 Click the Enter icon to calculate the average.

Accessing Excel 2007 functions

To access other functions in Excel:

 Using the point-click-drag method, select a cell range to be 
included in the formula.

 On the Formulas tab, click the drop-down part of 
the AutoSum button.

 If you don't see the function you want to use (Sum, Average, 
Count, Max, Min), display additional functions by selecting More 
Functions.

 The Insert Function dialog box opens.

 There are three ways to locate a function in the Insert 
Function dialog box:

o You can type a question in the Search for a function 
box and click GO.

o You can scroll through the alphabetical list of functions in 
the Select a function field.
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o You can select a function category in the Select a 
category drop-down list and review the corresponding 
function names in the Select a function field.

 Select the function you want to use, then click the OK button.



Sorting, Grouping, and Filtering Cells
        

                                             

A Microsoft Excel spreadsheet can contain a great deal of information. With more rows and columns than 

previous versions, Excel 2007 gives you the ability to analyze and work with an enormous amount of 
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data. To most effectively use this data, you may need to manipulate it in different ways.

A Microsoft Excel spreadsheet can contain a great deal of information. Sometimes you may find that you 

need to reorder or sort that information, create groups, or filter information to be able to use it most 

effectively.

Sorting

Sorting lists is a common spreadsheet task that allows you to easily reorder your 
data. The most common type of sorting is alphabetical ordering, which you can 
do in ascending or descending order.

To sort in alphabetical order:

 Select a cell in the column you want to sort (In this example, we 
choose a cell in column A).

 Click the Sort & Filter command in the Editing group on the 
Home tab.

 Select Sort A to Z. Now the information in the Category column is 
organized in alphabetical order.
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You can Sort in reverse alphabetical order by choosing Sort Z to A in the list.

To sort from smallest to largest:

 Select a cell in the column you want to sort (a column with 
numbers).

 Click the Sort & Filter command in the Editing group on the 
Home tab.

 Select From Smallest to Largest. Now the information is 
organized from the smallest to largest amount.

You can sort in reverse numerical order by choosing From Largest to Smallest in 
the list.

To sort multiple levels:

 Click the Sort & Filter command in the Editing group on the 
Home tab.

 Select Custom Sort from the list to open the dialog box.
OR

 Select the Data tab.

 Locate the Sort and Filter group.

 Click the Sort command to open the Custom Sort dialog box. 
From here, you can sort by one item or multiple items.

 Click the drop-down arrow in the Column Sort by field, then 
choose one of the options—in this example, Category.
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 Choose what to sort on. In this example, we'll leave the default 
as Value.

 Choose how to order the results. Leave it as A to Z so it is 
organized alphabetically.

 Click Add Level to add another item to sort by.

 Select an option in the Column Then by field. In this example, we 
chose Unit Cost.

 Choose what to sort on. In this example, we'll leave the default 
as Value.
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 Choose how to order the results. Leave it as smallest to 
largest.

 Click OK.

The spreadsheet has been sorted. All of the categories are organized in 
alphabetical order, and within each category the unit cost is arranged from 
smallest to largest.

Remember that all of the information and data is still here—it's just in a different
order.

Grouping cells using the Subtotal command

Grouping is a useful Excel feature that gives you control over how the information is displayed. You 

must sort before you can group. In this section, we will learn how to create groups using the Subtotal 

command.

To create groups with subtotals:

 Select any cell with information in it.



Devi Ahilya Arts & Commerce College , Indore

 Click the Subtotal command on the Data tab. The information in 
your spreadsheet is automatically selected, and the Subtotal dialog
box appears.

 Decide how you want things grouped. In this example, we will 
organize by Category.

 Select a function. In this example, we will leave the SUM function 
selected.

 Select the column where you want the Subtotal to appear. In this 
example, Total Cost is selected by default.

 Click OK. The selected cells are organized into groups with 
subtotals.
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To collapse or display the group:

 Click the black minus sign, which is the hide detail icon, 
to collapse the group.

 Click the black plus sign, which is the show detail icon, to 
expand the group.

 Use the Show Details and Hide Details commands in the Outline
group to collapse and display the group as well.

To ungroup select cells:

 Select the cells you want to remove from the group.

 Click the Ungroup command.

 Select Ungroup from the list. A dialog box will appear.

 Click OK.
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To ungroup the entire worksheet:
 Select all cells with grouping.

 Click Clear Outline from the menu.

Filtering cells

Filtering, or temporarily hiding, data in a spreadsheet is simple. This allows you 
to focus on specific spreadsheet entries.

To filter data:

 Click the Filter command on the Data tab. Drop-down arrows will 
appear beside each column heading.

 Click the drop-down arrow next to the heading you would like to 
filter. For example, if you would like to only view data 
regarding Flavors, click the drop-down arrow next to Category.
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 Uncheck Select All.

 Choose Flavor.

 Click OK. All other data will be filtered, or hidden, and only the 
Flavor data is visible.

To clear one filter:

 Select one of the drop-down arrows next to a filtered column.

 Choose Clear Filter From...
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To remove all filters, click the Filter command.

Microsoft Office Button: 

The Microsoft Office button appears in the top left corner of the window and includes basic file
functions such as New, Open, Save, and Print.

Tabs: 

The many buttons and menu options required to create and edit presentations are grouped into

MS- POWERPOINT - 2007
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seven distinct categories and accessible from tab-like buttons which appear across the top of the
window.

Ribbon: 

The ribbon contains the buttons and menu options specific to each tab for creating and editing
presentations.

Current Slide: 

The current slide appears in the middle of the screen and contains the contents of a particular
PowerPoint slide.

Outline or Slides Tab: 

The Slides tab displays thumbnails of all slides in a presentation. The Outline tab displays an
automatically generated outline of the presentation.

Help button: 
The help button in the top right corner of the window provides access to an index of help topics
as well as a key-word search of the extensive help files.
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Lower Toolbar:

 The lower toolbar allows easy toggling between viewing options and also displays the 
number of the slide currently on screen.

Tabs and the Ribbon

The ribbon includes seven tabs to choose from. After selecting a tab, the ribbon will 
automatically update to display the appropriate menu options and buttons. The menu options and
buttons are grouped by functional category into distinct toolbars.

More Options 
button to display a pop-up window with the full set of menu options and buttons for that 
category. The More Options button is square-shaped with an arrow.

Home Tab

The Home tab includes basic functions for creating and manipulating a presentation. The 
toolbars that make up the Home tab include Clipboard, Slides, Font, Paragraph, Drawing, and 
Editing. Example menu and button options include copying and pasting, adding a new slide, 
adjusting fonts and paragraph formatting, and basic drawing features.

Insert Tab

Use the Insert tab to add a wide variety of content into a presentation including tables, charts, 
images, links, text boxes, audio, and video. The toolbars that make up the Insert tab include 
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Tables, Illustrations, Links, Text, and Media Clips.

Design Tab

The Design tab provides a variety of options for designing and formatting a presentation. Use the 
Design tab to manipulate the page setup, color themes, and backgrounds of a presentation. The 
toolbars that make up the Design tab include Page Setup, Themes, and Background.

                 

Animations Tab 

Use the Animations tab to add, customize, and preview animations and transitions between 
slides. The toolbars that make up the Animations tab include Preview, Animations, and 
Transition to This Slide.

Slide Show Tab

Manage the settings for showing a presentation with the Slide Show tab. The toolbars that make 
up the Slide Show tab include Start Slide Show, Set Up, and Monitors.
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Review Tab

The Review tab provides access to proofing features like spell check and also allows for 
embedding comments in a presentation. The toolbars that make up the Review tab include 
Proofing and Comments.

View Tab

The View tab presents a number of options to specify how to view a presentation such as hiding 
or displaying notes, hiding or displaying gridlines, zooming in and out, displaying in gray scale, 
and more. The toolbars that make up the View tab include Presentation Views, Show/Hide, 
Zoom, Color/Grayscale, Window, and Macros.
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Create a New Presentation

To create a new presentation,
 Click the Microsoft Office button and select New. The New Presentation pop-up 

window will appear,
Choose to start with one of Microsoft‘s Installed Templates, Installed Themes, or a Blank 
presentation to create a customized presentation.

 Click the Installed Themes menu option to browse through the available graphical 
themes. Select one that will work for the presentation.

 Click the Create button in the lower right-hand corner.
Or

To create a completely custom-designed presentation,
 Select the Blank and recent menu option.
 Click the Blank Presentation button and then the Create button in the lower right-hand 

corner.

Design a Presentation

PowerPoint includes a number of ready-made design themes. These themes serve as the basis for
the graphic design of a presentation. Each theme consists of a background design, placeholder
layouts, a color palette, and font styles. To browse through the available themes, click the Design
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tab in the ribbon.. Click a particular theme to apply it to the presentation.
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To skip the ready-made themes in order to create a custom-designed presentation,
 Select the Design tab in the ribbon.
 Click the Background Styles menu to choose the background.
 Click the Colors, Fonts, and Effects menus in the Themes toolbar to customize the design

of the presentation.
 To customize a ready-made theme, click an element within a slide.
 Select the Design tab and then choose from the various options available from the Colors,

Fonts, and Effects menus in the Themes toolbar.
 Adjust the Background using the Background Styles menu in the Background toolbar.

Insert a New Slide

To insert a new slide into a presentation,
 Click the Home tab in the ribbon.
 In the Slides toolbar, select the New Slide button

Save the Presentation
To save a presentation,
Click the Microsoft Office button and choose Save As.

Charts

Charts and graphs are an effective way to present information than a simple list of numbers.
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PowerPoint 2007 is fully integrated with the spreadsheet tools of Excel 2007, making it very
easy to create a chart from scratch or to import data from an existing spreadsheet.

Creating Charts

1. Select the slide where you want the chart to appear.

2. In the Insert tab, under the Illustrations group, click on CHART  to open

the Insert Chart dialog. 

3.

                                                                   

4. Select the type of chart from the category list on the left, or simply scroll through the 
gallery on the right to view all the available charts. Once you have made your 
selection, click OK.

5. The chart will appear on your slide, and Excel will open as a split screen with dummy
data already filled in.

6. Add your data and labels to the Excel spreadsheet and the chart will be automatically
updated on your slide.

7. When finished, click the    in the upper right hand corner of Excel to close 
the worksheet..

Animation
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PowerPoint allows you to animate objects  or specific  content within a slide and also to add
animated  transitions  between  slides.  Transitions  are  a  common and easy  way to  liven  up a
presentation.

Add Transitions

To add a consistent transition between each slide throughout the presentation, follow these 
instructions.
1. Click the View tab and click the Slide Master button.
2. In the left-hand Slides tab, select the first slide which is numbered ―1.‖
3. Click the Animations tab.
4. In  the Transition to This Slide toolbar, browse through the transition options and click the
appropriate choice. Place the mouse over each option to preview the transition within the slide
currently on screen.
5. When satisfied with the transition, click the Slide Master tab and then the Close Master View
button.

 Add
Animation

With PowerPoint, you can animate virtually any object or specific content that appears on a  
slide.

 To animate an object or content, select it.
 Click the Animations tab.
 Select from the menus and buttons available in the Animations toolbar.
 After selecting the appropriate animation settings, use the Preview button to see the 

animation in.

Audio
To add audio to a presentation
1. Click the Insert tab.
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2. Then click the Sound button.
3. Navigate to the correct audio clip and select it.
4. A pop-up window will ask if the audio should play Automatically or When Clicked.
5. An audio icon will automatically appear on the slide. To preview the audio, right click 
the audio icon and select Preview.

Inserting and Format Picture Tab:-

You can even insert the image in your presentation. To insert click on insert option and then on
picture, a window will open you can insert the picture from any desired location.

After you insert an image the Picture Tools - Format tab will automatically appear.

Adjust Picture Settings

The Adjust group on the Picture Tools tab allows you to 

adjust the brightness and contrast of your image. You can 

also use the recoloring options to change the tint of your 

picture.

Borders and Effects

With the Picture Styles group you can add some interesting effects to your images, including 
regular borders and shaped borders, shadows and reflections, and 3-D rotation options.

Recording your own sounds Adding 
Notes

There are two ways to insert notes in PowerPoint.
1. To insert short notes: In the Normal view, click on the Notes box at the bottom of your 
screen and type your text.

2. To insert longer notes: Click on the View tab. Under Presentation Views select the Notes
Page button. Type your notes in the space that appears below your slide.

Inserting Headers & Footers
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To add a header and footer, click on the Insert tab, then on the Header & Footer 

button. The Date & Time and Slide Number buttons will bring up the same dialog box.

1. Fixed and Automatic Dates - PowerPoint gives you the option to add either a fixed date and
time, which will remain the same, or a date and time that automatically update. If you choose to
have a date and time that automatically update, the date and time will always match the date and
time that you run your slide show.
2. Slide Number - Check this box to show the slide number.
3. Footer - Check the Footer box and add text to have text appear at the bottom of the slide.
4. Apply/Apply To All - To insert your chosen elements into your slide, select  Apply to have
the information appear only on your current slide, or Apply To All to have it appear on every
slide. If any of the information is repeated on  the title slide, check the  Don't show  on  title
slide box to avoid repeating the information.
5. Preview - The Preview box shows you where on your slide the information will appear. You
can not change this from within this screen, but once you insert the information you can click
and drag the box anywhere in your slide, just like any other text box.
Note: If you chose to Apply To All, moving the text box in one slide will not effect the placement

of the information in the rest of your slides.

6. Notes and Handouts - Under this tab, you can choose your header and footer preferences for
your handouts.

          Impotent link for MS- POWERPOINT –
          
                  https://youtu.be/0k92PUtdSFY
                  https://youtu.be/54rI3s1gyzQ
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Define internet

Introduction:  -  the  internet  is  a  global  network  of  interconnected  computers,
enabling users to share information along multiple channels. Typically a computer
that connects to the internet can access information from a vast array of available
servers and other computers by moving information from them to the computer‘s
local memory.

From a social point of view – the internet is a device through which millions of
people are communicating and sharing their idea and information.

From a technical point of view – the internet is a network of thousands of computer
networks. Together the networks making up the internet consist of over million
computer systems.

Growth of internet: - internet started as a government project in the US, has spread
all across the world connecting thousands of networks and millions of people Is an
amazing truth today. The growth of internet can be estimated by the fact that users
on internet were only 124 millions in 2000 while it increased to 175 millions in
2004 only in the United States. The current internet subscriber base in India is 3.3
millions.

Owner of internet: - the internet has no president nor has it a CEO the ultimate
authority on the internet is the internet society, which is a voluntary membership
organization whose purpose is to promote global information exchange through the
internet technology.

Advantages of internet:

1. Information

2. Entertainment
3. Services
4. News
5. E-commerce
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6. Communication
7. Formation of communities

Disadvantages:

1. Spamming
2. Theft of personal details
3. Pornography

INTERNET SERVICE PROVIDER (ISP):-

A company that provides internet access is known as internet service provider. A 
ISP charge for its services. In general ISPs take two types of fees:

 A charge for using the internet

 A charge for a physical connection to the internet

Use charges are billed at a fixed rate, ISPs do discriminate among classes of users.
An ISP might provide dial up access, a cable connection, an ADSL connection or
other types of internet access. In India there are more than 150 ISPs ( including
BSNL, Airtel , etc)

Kinds of connection

1. Dialup accounts
2. ISDN(Integrated Service Digital Network):

3. Broadband :

                             Applications of Internet
Internet is today one of the most important part of our daily life. There are large numbers
of things that can be done using the internet and so it is very important. You can say that
with the progress in the internet we are progressing in every sphere of life as it not only
makes our tasks easier but also saves a lot of time. Today internet is used for different
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purposes depending upon the requirement. Here in this very article we have mentioned
then ten best uses of the internet.

                            

 Domain Name System

A domain name is a unique name that identifies a website. For example, the domain 
name of the Tech Terms Computer Dictionary is "techterms.com." Each website has 
a domain name that serves as an address, which is used to access the website.

Whenever you visit a website, the domain name appears in the address bar of the 
web browser. Some domain names are preceded by "www" (which is not part of the 
domain name), while others omit the "www" prefix. All domain names have 
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a domain  such as .com, .net, or .org. The domain suffix helps identify the type of 
website the domain name represents. For example, ".com" domain names are 
typically used by commercial website, while ".org" websites are often used by non-
profit organizations. Some domain names end with a country code, such as ".dk" 
(Denmark) or ".se" (Sweden), which helps identify the location and audience of the 
website.

Domain names are relatively cheap to register, though they must be renewed every 
year or every few years. The good news is that anyone can register a domain name, 
so you can purchase a unique domain name for your blog  or website. The bad news 
is that nearly all domain names with common words have already been registered. 
Therefore, if you want to register a custom domain name, you may need to think of a
creative variation. Once you decide on a domain name and register it, the name is 
yours until you stop renewing it. When the renewal period expires, the domain name 
becomes available for others to purchase.

URL (Uniform Resource Locator)

A URL (Uniform Resource Locator) is a unique identifier used to locate a resource 
on the internet. It is also referred to as a web address. URLs consist of multiple parts 
-- including a protocol and domain name -- that tell a web browser how and where to
retrieve a resource.

End users use URLs by typing them directly into the address bar of a browser or by 
clicking a hyperlink found on a webpage, bookmark list, in an email or from another 
application.  Example of URL-

https://searchnetworking.techtarget.com/definition/URL

Web Browser
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web Browser is an application software that allows us to view and explore 

information on the web. User can request for any web page by just entering a URL 

into address bar.

Web browser can show text, audio, video, animation and more. It is the 

responsibility of a web browser to interpret text and commands contained in the 

web page.

Earlier the web browsers were text-based while now a days graphical-based or 

voice-based web browsers are also available. Following are the most common web 

browser available today:

Browser Vendor

Internet Explorer Microsoft

Google Chrome Google

Mozilla Firefox Mozilla

Netscape Navigator Netscape Communications Corp.

Opera Opera Software

Safari Apple

Sea Monkey Mozilla Foundation

K-meleon K-meleon
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Common Parts of Browser-

 Address Bar
 Main Window
 Back/Forward Button
 Stop Button
 Refresh Button
 Status Bar

Search Engine-

Search Engine refers to a huge database of internet resources such as web pages, 

newsgroups, programs, images etc. It helps to locate information on World Wide 

Web.

User can search for any information by passing query in form of keywords or 

phrase. It then searches for relevant information in its database and return to the 

user.
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Search Engine Components

Generally there are three basic components of a search engine as listed below:

 Web Crawler
 Database
 Search Interfaces
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Web crawler

It is also known as spider or bots. It is a software component that traverses the web 
to gather information.

Database

All the information on the web is stored in database. It consists of huge web 
resources.

Search Interfaces

This component is an interface between user and the database. It helps the user to 

search through the database.

Examples

Following are the several search engines available today:

Search 

Engine

Description

Google It was originally called BackRub. It is the most popular search 

engine globally.

Bing It was launched in 2009 by Microsoft. It is the latest web-based

search engine that also delivers Yahoo’s results.

Ask It was launched in 1996 and was originally known as Ask 

Jeeves. It includes support for match, dictionary, and 

conversation question.
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AltaVista It was launched by Digital Equipment Corporation in 1995. 

Since 2003, it is powered by Yahoo technology.

AOL.Search It is powered by Google.

LYCOS It is top 5 internet portal and 13th largest online property 

according to Media Matrix.

Alexa It is subsidiary of Amazon and used for providing website 

traffic information.

Website

Website is a collection of related web pages that may contain text, images, audio and
video. The first page of a website is called home page. Each website has specific 
internet address (URL) that you need to enter in your browser to access a website.

Website is hosted on one or more servers and can be accessed by visiting its 
homepage using a computer network. A website is managed by its owner that can be 
an individual, company or an organization.

Static website

Static website is the basic type of website that is easy to create. You don't need the 
knowledge of web programming and database design to create a static website. Its 
web pages are coded in HTML.

The codes are fixed for each page so the information contained in the page does not 
change and it looks like a printed page.

Dynamic website is a collection of dynamic web pages whose content changes 
dynamically. It accesses content from a database or Content Management System 
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(CMS). Therefore, when you alter or update the content of the database, the content 
of the website is also altered or updated.

Dynamic website

Dynamic website uses client-side scripting or server-side scripting, or both to 
generate dynamic content.

Client side scripting generates content at the client computer on the basis of user 
input. The web browser downloads the web page from the server and processes the 
code within the page to render information to the user.

In server side scripting, the software runs on the server and processing is completed 
in the server then plain pages are sent to the user.

How To Create Email Account  On Yahoo.Com?

To access Yahoo! mail, you need to create a 

Yahoo! account. Here's how.

1. Navigate to the Yahoo! account sign up page.

2. Fill out the required fields (A) and then click 
the Continue (B) button.
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3. Click the  
button.

4. Enter the five-digit key, and then click 

the  butto
n.

5. Click the  
button.
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6. Click the  icon.

How to create a Gmail account?

You can use your username and password to sign in to Gmail and other Google 

products like YouTube, Google Play, and Google Drive. Follow the steps, create 

your Gmail account and start sending emails.

Step 1: Visit Google account creation page, accounts.google.com

Step 2: Click on Create account.

Step 3: The sign-up form will appear. Enter your first and last name.

Step 4: Choose a Username for your account. (Here you can also use an existing 

email address)

Step 5: After choosing a username, enter a password. Type the password again to 

confirm. (As per Google's instruction always use 8 or more characters with a mix of 

letters, numbers & symbols)

Step 6: At last tap on Next. (Right corner of the screen)

Step 7: On the next page enter your phone number to verify your account. (It is a 

two-step verification process for security)

Step 8: On the given mobile number you will receive a text message 

from Google with a verification code. Enter the verification code and tap 

on Verify.

Step 9: On the next page enter your DOB in the specified fields.

Step 10: Choose a Gender.
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Step 11: Tap on Next.

Step 12: Read, Google's Terms of Service and Privacy Policy will appear on 

the screen and click on I agree.

Congratulations! your account has been created. From now onwards every 

time you sign in you just have to enter your email id and password. And 

every time you sign-in don't forget to sign-out because it prevents others 

from viewing your emails. Do you know how to sign-out?

Navigate to the circle(in the top-right corner of the page). Here tap on it, 

from the below option, select Sign-out.

Follow these step-by-step instructions to send an email
Step 1: Log in to your Gmail account so that you are on the dashboard (main
page) of your mail account.

Step 2: Click Compose.

                    

Step 3: A new blank email window will open up. In the ‘To’ box, type in the 
email address of the recipient.
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Step 4: You might want to include someone else in your email to ‘keep them 
in the loop’. You can do this by clicking Cc or Bcc, which will open another 
field. ‘Cc’ means ‘carbon copy’ and ‘Bcc’ means ‘blind carbon copy’. Adding 
an email address to the ‘Cc’ field means that that person will receive a copy 
of the email and all the other recipients will see their email address. If an 
email address is put into the 'Bcc’ field, the person will get a copy of the 
email but no other recipient will see that address.

If you are sending the same email to lots of different people, it’s a good idea 
to put all the email addresses in the ‘Bcc’ field to keep your ‘mailing list’ 
confidential. That way, there’s no chance that it could fall into the hands of a 
spammer or hacker.
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Step 5: The subject field allows you to give the recipient an idea of the topic 
of your email, like a heading. You don’t have to put anything in the subject 
box, but it can help when viewing and sorting email.

Step 6: Email text can be formatted in a similar way to text in a word 
document. You can change the font style, colour and size using the 
formatting icons. You can also create bullet points and check the spelling of 
your email. Choose your formatting from the menu shown.

 Step 7: Type your message in the main body field of your email.
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You can format your email using the options that are available on the toolbar.
To add a link in the body of your email click on the insert link icon, then add 
the 'Text to display' and then a web or email address, finally click OK.
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Step 8: When you’re happy with your email, click the blue Send button at the

bottom of the compose window.
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Step 9: The email you’ve sent will now be stored in the ‘Sent Mail’ folder on 

your Gmail dashboard. You may have to run your mouse pointer over the 

Inbox folder link to see the other folders.
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Step 10: You may start an email but then decide to come back to it later 

rather then sending it straightaway. Gmail saves your drafts automatically. 

So you can simply close the email and the unfinished email will be saved to 

your ‘Drafts’ folder.  When you decide that you’re ready to send it, you can 

retrieve it from the ‘Drafts’ folder by clicking Drafts and then clicking the 

correct item in the ‘Drafts’ folder list. Finish the email and click Send as 

normal.
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Introduction to firewall: -

A firewall is an executable code , the attacker could compromise that code and
execute from the firewall device. A firewall is a computer that sits between internal
network  and  the  rest  of  the  network  and  attempts  to  prevent  bad  things  from
happenings

Firewall uses the following technique to control access and enforce the site‘s security
policy:

1. Service control – determine the types of internet service that can be accessed
inbound or outbound.

2. Direction control – decides direction for initiation of service request and 
allowed to flow through the firewall.

3. User control – controls access to a service ,which user is attempting to access 
it.

1. Behavior control – controls how particular services are used. For example 
the firewall may filter e-mail to eliminate spam.
Types of firewall: -

1. Packet filtering router
2. Application gateways
3. Circuit level gateway
4. Stateful packet inspection firewalls
5. Guard
6. Personal firewall

Pop-up blocker: - a pop-up blocker refers to any software or application that
disables any pop – up , pop over or pop under advertisement window that you
would see while using a web browser. Some pop up blockers may try to close all
pop – up windows ,some may remove all advertisement from a publisher‘s web
site , an still others may help you choose which popup windows you want to be
closed with block list feature.
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Virus:-

A computer virus is a program or piece of code that is loaded onto your
computer  without  you  knowledge  an  runs  against  your  wishes.  All
computer virus are man made. A few prominent virus are Michelangelo,
dishwasher, C-brain , macmag , nenusalem , columbus etc.-

How a virus spread :

1. Using a paired device

2. Through network system
3. Through secondary storage devices
4. Through internet

Types of computer virus : -

1. Boot sector virus - these types of viruses get themselves stored
in th boot sector of floopy and hard disk. When we boot a
computer system it hinders the loading of oprating system.

2. Partition table virus – these kind of viruses affect the partition
table of hard disk but do not affect the data in the computer.it
only affects MBR(master boot record) of the hard disk.

3. File virus- this kind of virus get associated with executable
files. When an EXE file is executed , virus may executes to
affect the computer system.

4. Stealth v-virus – a stealth virus is a computer virus that makes
every effort to conceal its presence from the user.

5. Polymorphic virus – a polymorphic virus is one that is capable
of  changing  itself  so  that  each  infection  of  the  virus  is
completely different from the original.


